[F] Mouse movement locked to X Axis

My mouse works fine in all the menus etcetera, but once the game launches and I press a keyboard button, my mouse ‘locks’ in the part it was and I can’t change the heading of my ships. All other controls keep working fine! So, after launch the mouse works perfectly, but once I press a keyboard button my mouse freezes in place. The mouse-buttons keep working, it’s just that the icon stays locked.



Charactername: Creative Walnut
What did you expect to see: My ship changing heading in game

What happened: The targeting reticule locks and I can’t change it by moving the mouse, it stays locked in place. All other buttons, including those on the mouse, work, just no mousemovement
What was your last action: Starting up the game
Is the bug reproduceable, if yes please describe how to reproduce the bug: Launching into a game



I am having the same issue. All of the mouse buttons work, I am just unable to steer my ship. I have tried resetting the keybinds, changing the ship control(basic, expert), alt-tabbing, restarting, and re-installing. None of these fixed my issue.

same issue here. No starship navigation controlls. Only accelleration.

Does any of you have a controller plugged in?

Does any of you have a controller plugged in?

I don’t have a controller plugged in.

If this is still happening: Attach the log files from: My Documents/My Games/Star Conflict/logs

I can’t aim by cursor only by changing ship position i can normaly shoot but not to aim, also i didn’t recieve any refund from modules ive lost. :<

Charactername: TuuheaTakasumu
What did you expect to see: Steerable torpedo.

What happened: Unsteerable torpedo.
What was your last action: Start game, join squad and join a match.
Is the bug reproduceable, if yes please describe how to reproduce the bug: Play any match.
Please attach at least one screenshot or make a little video of the issue:

Settings: http://youtu.be/rSvnV0FgeY4

Inflight: http://youtu.be/Z88pgl1skI0

How pitch control worked before: http://youtu.be/a4pD7PLBf1Y?t=20s

What are your system specs: Phenom 2 965 3.4GHz, 16GB ram, 2x radeon 5750, ikari laser and logi keyboard. No extra controllers attached or software installed.


Also discovered that there is no pitch control for empire sniper module. When tried expert control mode I had exactly the same problem as the OP. Videos have basic control mode.


game.log: http://pastebin.com/6BrFSUgF

This problem still persists in 0.8 patch 1. Pitch aim is still locked to horizontal plane.


Apparently here’s how it should work:


Notice the aiming reticule moving freely.


Here’s how it works for me for reasons unknown: http://youtu.be/5T6uVTpndSI


Notice how aiming reticule is locked to horizontal plane and instead up and down aiming moves the entire view. This causes motion sickness for me and I cannot play more than 10 minutes. Also hitting targets is much more difficult for some reason.


Log: http://pastebin.com/qiYSTn2y

i am also seeing this reticule axis lock , and expert controls lacking any aim or anything from mouse


this is an amd FX 8120 amd radeon 6970 razer blackwidow kb, and a gigabyte mouse, on win 7 x64, game logs didn’t seem to have errors of any kind related to this, just some loading boss descriptors, and loot things being out of the window

yep i cant controll my ship with my mouse eather …pls help

Try to delete the “user_config.xml” All settings for mouse input are saved there for the game. You need to set any custom done settings again but this may help. Otherwise its more a driver/hardware related problem.

Did a full reinstall, removed all registry entries etc. Problem still persists.

No matter what I do, I cannot control the guided Torpedo. I even tried the steam version of the game. I can control my ship just fine, but not the guided torpedo.



Same problem here.




Game complete reinstall via steam and launcher

all registry entries deleted for game and also old ones for mouse drivers

tmp folder cleaned

user_conflig.xml deleted and also modified one tested

windows updates done

mouse driver updates done

tested with a different mouse, Logitech MX 518, same problem



[DxDiag.zip](< base_url >/applications/core/interface/file/attachment.php?id=5945)

[user_config.zip](< base_url >/applications/core/interface/file/attachment.php?id=5946)

[game.zip](< base_url >/applications/core/interface/file/attachment.php?id=5947)

1-problem in the x
2- that the x-axis never remained static in half
4- range up to 12 and out
5- the x axis is kept statically in the middle while the axis and moves freely
6- AMD 6 fx mother asus acx-90 pro 8gb the ram ddr3 sniper gol 1833 mhz ATI 7790
7- do not upload a video that do not take a picture and think it’s ridiculous because a picture does not show the problem is the same that I saw in all the videos that went up the most people, I hope you can tell me how solve since 1 week I’m unable to play because of this bug.


it’s just a shame that a bug so this circulating in the game, is something that affects all the gameplay severe and not solve? I for 1 week I can not play because I can not simply point is sad to see them leave a bug of this magnitude and not corrected

someone could fix this problem or wait staff that gets fixed I to know and not go to the expectation playing this way I’ve been one week so

topics of the same issue merged

We need a DX Diag File from all who have this issue.