Won't launch game on mac!

The game will download but when i go to play it the game will pop up and then disappear and say not responding. I have the most up to date versions of everything with plenty of space to hold the game. I really want to play can someone please help me. 




Hello. Please follow the outline for bug reporting. It makes it easier to help.

  1. Describe the bug in a few words/sentences.
  2. Why do you think this is a bug.
  3. How often does this bug occur.
  4. What was your last action/How to reproduce the bug.
  5. Detailed explanation of the bug.(Only if you need to add more information to 1.)
  6. Your system specs + Operating system as DX Diag.
  7. Videos + Screenshots (Only if needed, but in most cases they are helpful)
  8. Log files + Exceptions
    (Please only add the Logs and Exceptions of the game session where the bug occured, not all!)
    (Logs can be found here: My Documents\My Games\StarConflict\logs)
    (Exceptions can be found here: My Documents\My Games\StarConflict\Exceptions
    (Upload the logs + exceptions as a .zip archive, not .rar!)
    (In case of game freezes or crashes, you should launch the game in window mode to have acess to your system)

ok my bad thanks for the tip. 

the game won’t respond/launch to let me play it. I downloaded it from steam and when i go to play it. It just closes.

I think this is a bug because i have the current updates for m mac and it still won’t run.

This bug occurs every time i try to play the game i have never been able to load the game successfully once.

I just downloaded the game and tried to play it and it wouldn’t launch.

my mac has the latest 10.9.2 update.a 2.5 GHz intel core i5. and 4Gb of free memory. 

I don’t think there is any need for video since the nothing happens which is the problem.

This has been a problem for a couple months now. The game does not launch through steam for whatever reason. They said a while back they figured it out and had fixed it but it still persists.

To launch the game you have to find it and launch it manually. The game is found at ~/Library/Application Support/Steam/Steam Apps/Common/Star Conflict/

This still hasn’t been fixed with the 0.10.0 update. The game can only be launched once from steam, then to launch it again you must restart steam or launch it by navigating to the application manually.

Restarting steam fixes this problem, nevertheless, it is very annoying…

Sorry for the wait, this bug is in work.

i know how to fix this 


either manually find and run the app


its in the common folder 


or restart steam


happens occasionally not to serious in my opinion but it needs to be fixed for though who don’t know where to find the app


and put an aias of the actual app in the applications folder so you can access it when this happens

I have the exact same problem; thanks for the info on how to fix it. I hope it’ll get fixed soon; Star Conflict looks like a great game, would be sad to have it be hindered by such a problem.