Update makes Star Confict freeze for seconds

After the last update, in any game mode (invasion, PvP, PvE) the game will freeze up to a second whenever a ship blows up. The game will crash if my ship is blown up. There is also a delay when changing screens from hangar to wait screen to briefing to space. Sound comes before graphics during these load times. Is anybody else experiencing this or is it just me?

I have the same problem. Running Archlinux with

nvidia 346.59-1

kernel 3.19.3-3

I am experiencing this as well.  It doesn’t just happen for me when ships blow up, but it seems to happen periodically about once a second, with some stutterings being more noticeable than others depending on what’s going on in the game at the time.  It’s most noticeable during explosions, or when a new wave of ships arrive.  Thinking that this was a driver issue, I tried nvidia-331, nvidia-331-updates, and nvidia-346 – all with the same video stuttering results.  I have tried limiting the video to 30fps, and turning all graphics capabilities as far down as they will go, but to no avail.


This is on a fully up-to-date Ubuntu 14.04 system on a System76 Bonobo laptop with an Intel Core i7-4810MQ CPU, nVidia GeForce GTX 870M w/ 6GB, and 16GB RAM.  This machine should have absolutely NO problems playing this game even at full settings.


Currently I consider the game unplayable, and I hope they get this problem fixed a.s.a.p.

Here are the relevant files.

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9044)

[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9045)

[user_config.xml](< base_url >/applications/core/interface/file/attachment.php?id=9046)

igsNomad & Bendable

Please provide game.log and game.net.log too. Thanks.

will be fixed in next update

Ok, here are my logs:



[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9051)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9052)

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9053)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9054)



[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9055)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9056)

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9057)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9058)


[user_config.xml](< base_url >/applications/core/interface/file/attachment.php?id=9059)

Relevant logs attached

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9060)

[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9061)

Thanks for your quick reply. Is there anything I can do on my side that might fix it? For example not use a NVIDIA videocard.

If you need help testing the patch let me know.

same issues here on modern hardware (i7-4790K, 32GiB RAM, Geforce GTX 970)

My problem is the exact same as other players in game. Although, I am coming at it from not just a game player’s perspective but a programmer’s angle. too.


Here’s what I know so far;


Makes no difference what:


* Distribution of Linux you’re using.

* Kernel version starting with 3.2 (3.02, really) up to current 3.19.x.

* Kernel architecture you’re using; i386, i686 or x86_64 kernels.

* The graphics cards that are supported; Any OpenGL 3 card with 1 GB RAM should do fine; Intel (ATI in diguise often times), ATI / AMD HD and R     series, Nvidia 2xx and up should work fine.

* Speed your main memory is, as long as it’s 800 MHz DDR2 and higher.

* Graphics options you set, including resolution in game.

* CPU you use for as long as it meets the minimum requirements.

* If you have VSYNC enabled or not

* If you have your textures uncompressed, compressed or highly compressed (ATI optimizations found in the Catalyst Control Center, etc.).

* Overclocking, underclocking or normal clocking your graphics card.


What the problem with the lag and stuttering has to do with the crediting of kills and the animations destructions of ships. The explosions don’t even have to be on radar but you can hear them, that will affect the perceived lag. It seems like an A.I. 3-D space collision detection system gone awry. In the before the now 3 releases prior to this, everything worked great for me, I didn’t lag at all. Now, I lag even in practice runs, I won’t bother to get into PvE and PvP where the ping time will worsen the perceived lag, even if my ping time is in the green 20 to 40 ms, that’s enough to screw me up with this microstuttering when targeting and blowing enemies up, even if it’s not me doing it. Happens either way.


What I am saying is, makes no difference about the hardware and the software in the system, it’s the binary Star Conflict that has the bug, nothing else.


Note: I can play other games like Team Fortress maxed out and have no issues at all, as well as heavy graphics intense games with all the bells and whistles turned on in PvP over the Internet, no trouble there.


If you want me to send the logs, I will, but I am sure the logs will bear out the same information you’ve been seeing from other peoples’ machines and configurations.

Same here, Im running Ubuntu and, as decribed, I have these problems arriving to battles, blowing ships and switching mission phases. The game worked perfectly until the first dreadnought update, now as It was told here the lags make it nearly unplayable.

Please fix it, and if it’s already an update date, tell me.


Thanks for your time,


Thanks. Please keep in mind to provide the log-Files.


The lag should be gone now, isn’t it?

I havent tried today. yesterday 13 of april around 22:00 CET +1 it wasnt resolved yet.

Did receive an update of starconflict yesterday and a new update of steam today.

I havent tried yet with the last update of steam itself. I will try again tonight and let you know.


If you need log files of yesterday last night let me know. I did play for a while and sucked horrably cuz of the bug :smiley:

The problem persists although a little more tame, here are my logs from after yesterday’s update and today’s:


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9090)

[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9091)



[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9092)

[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9093)

still unplayable slow after 2 mini patches ;-(

Same here. Problem persists

The lag and stutters isn’t gone however it has been massively improved. There is still the lag that occurs when you, a team mate or the A.I. blows up an enemy. It happens in all modes of the game including the practice sessions under “Help”. Once in a great while if there is a lot of motion in the 3-D space where I am located I might get a lag for a brief 1/4 second, it’s enough to throw me off my game so to speak.


Attached are my logs I have in my system as it pertains to this game:


2015.03.12 04.55.58


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9100)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9101)


2015.03.12 19.57.21


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9102)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9103)


2015.03.12 20.00.42


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9104)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9105)


2015.03.13 05.31.34


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9106)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9107)


2015.03.14 07.59.52


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9108)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9109)


2015.03.14 08.03.45


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=9110)[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=9111)


Perhaps these logs will help you track down the problem for us. Please do let me know if I can be of more assistance to you and the developers.



Here is my user configuration file, too, just in case you want that as well.


[user_config.xml](< base_url >/applications/core/interface/file/attachment.php?id=9112)

The description of QuantumQuark is exactly what I experiance