turkish keyboard doesnt support properly

i use turkish Q keyboard and game have bugs that misunderstand keys

here is my keyboard:


WP_20170223_15_52_15_Pro.jpg.758e4141ca326f37c8404758b528679f.jpgi know looks messy lol

i will show the problem comparing “ingame chat output” and “what sould be the output”

*first row (numbers row)

in game: "1234567890 -        (only * key not working, i placed space a there)

sould be: "1234567890*-


*first row with shift key

in game: é!’^+%&/()=Q_           (i placed Q for missing key, i cant use question mark ingame chat)

sould be: é!’^+%&/()=?_


*first row with ctrl+alt

ingame: <>£#$½ {[]} |           (same key doesnt work right crtl+alt+* sould give “” output and both crtl+alt+6 have no effect not a bug)

sould be: <>£#$½ {[]}|


*the key between left shift and Z wich is <

same problem with * actualy 

normally sould give “<” output but no effect when use

with shift key sould give “>”

and crtl+alt key sould give “|” same key for crtl + alt + “-” i have no idea who design this keyboard  ![:)](<fileStore.core_Emoticons>/emoticons/001j.png “:)”) 


oh wait while i testing ctrl+alt combination on latters i find that crtl+alt+T gives “?” output lol which has to be “₺” symbol of our currency “Turkish Lira” 

but there is no way to access * and \ keys on my keyboard rest works fine i tried every possible combinations

Pain of not having an english keyboard. Like my old keyboard was rrench Canadian, this one is American english.

On my old keyboard i had to change windows keyboard language setting and use notepad to find out what key is what. First time it took me forever to find the tidle key ( over TAB key) but was like on my apostrophe key. It was the same for some other keys, like the reversed slash key.

Have you tried setting windows keyboard language to Turkish?

Also, someone will most probably tell you, if not me. No logs= no bugs

i’ve tried english and turkish both it doesnt make diffrence. its bug and imo all turkish q keyboards have same issue 

someone in my corp and my old homemate had same problem