System hacks doesn't work on Remote Desintegrator in skirmish

what happened : the system hack didn’t remove the control or destroyed the Remote desintegrator of the R17 Project 1011 in skirmish battle .

expected to happen : destroy the drone like tested in custom battle .

conditions during the situation : beacon hunt on lava spines , enemy project 1011 used his special module to deploy the remote desintegrator , the system hack module of my zhen didn’t do anything to the remote desintegrator , despite having tried in custom battle , and seeing it destroying the remote minelayer in custom battle .

Further details on the issue: like said above , for some reason while trying to test it in a custom battle , the remote desintegrator get destroyed when using the system hack , but not in skirmish battle .

Frequency of occurrence: tried multiple time in skirmish , and multiple time in custom 

>i include the log , if somehow that can help you .
[chat.log](< base_url >/applications/core/interface/file/attachment.php?id=16812) [combat.log](< base_url >/applications/core/interface/file/attachment.php?id=16813) [game.log](< base_url >/applications/core/interface/file/attachment.php?id=16814) [](< base_url >/applications/core/interface/file/attachment.php?id=16815)

happened around 16:50 in the game time ( 17:50 on my time , GMC+1, france )