Strafe afterburners don't increase the ship's speed, just sound for afterburners is heard.

Bug report: (WIP)

 

 

Bug 1:

What happened?

When using regular speed when strafing, all is fine.

However, there’s no increased speed or noticeable effect when strafing with afterburners on all ships, but the sound effect for afterburner speed is active.

Energy capacity is depleting as well, despite no changes between regular strafe speed and strafe speed with afterburners.

 

Tested ships:

Mammoth, T-Rex, T-Rex Mark II, Caltrop, Dvergr, possibly all ships are affected.

 

What should have happened?

When using afterburners, you should strafe faster.

 

Bug 2:

Active afterburners don’t get proper visual effects.

When activating afterburners, you will not notice any additional/auxiliary engines engaged.

 

Tested ships:

Mammoth, T-Rex, T-Rex Mark II, Caltrop, Dvergr…

 

 

Videos:

 

 

Logs:

As bug 1:

There is no speed increase because strafe speed has no afterburner speed unlike forward and never had. With afterburners, only thing that increase is acceleration so you get max strafe speed faster.

 

As bug 2:

You dont use back engine to go sideways, so why it should light up?

Since our maneuvering thrusters already do this for rotation, we should make engines turn off once max speed is reached.

3 hours ago, Rob40468 said:

There is no speed increase because strafe speed has no afterburner speed unlike forward and never had. With afterburners, only thing that increase is acceleration so you get max strafe speed faster.

It isn’t faster.

 

3 hours ago, Rob40468 said:

You dont use back engine to go sideways, so why it should light up?

Because it’s used to be like that in the past, Caltrop model is the most obvious. Using afterburners directly activated 2 more side engines.

There were even some that activated only when going in reverse with used thrusters.

1 hour ago, Farfalla said:

Since our maneuvering thrusters already do this for rotation, we should make engines turn off once max speed is reached.

I agree!

The manouvering thrusters correctly shut off after reaching max strafe speed or max rotation speed while stationary.

 

They shouldn’t turn off while the ship is flying circles though. They currently do and it doesn’t make sense, since an object on a circular trajectory is constantly acceleration to the circles center…

 

But hey, Star Conflict physics! With projectiles suddenly disappearing after a set distance and bullets not moving relative to the ship firing them. Also ships having a set maximum speed despite the engines constantly running. Gravi lens pull should also be countered by a ships thrust and thus its max acceleration instead of its speed. And on top of all: an interceptor with a turning rate of 180deg/s and a top speed  of 600m/s would require an acceleration of 1200m/s, instead of the listed 200m/s…

 

It probably doesn’t make much sense to apply physics to this game. You’d have to explain how its possible to see a laser beam in a vacuum, first ![:D](<fileStore.core_Emoticons>/emoticons/006j.png “:D”)

Not a bug, but we gonna to review this feature 0092642