Steam troubles

Tried this, did not fix.  Still hangs up on “loading” after “connecting”.  I have d/l’d and installed ARC, I can launch from ARC and it never fails, I can Launch from the game’s folder directly and have no issues.  However if I try to use steam, it seems fairly wild as to wether it works or not.  Sometimes I can launch it from the game directory or from ARC and that (I guess) allows it to login from steam account next time, but not always.



  1. Launch the game from Steam Client, it loads normally, Select Log In, it says “Connecting”, then reads “Loading…” That is where it stops… wait for ten more minutes and it still won’t load.

  2. Prevents me from playing using my Steam Account which has 3,243 hours logged and I do not particularly want to start over.

  3. It happens every single day.  Once I do manage to get past “loading…” the first time, it can still occur again later the same day if I close the game entirely and relaunch the client from steam.

  4. Launching the game from the Steam Client, seems to be the only way to reproduce the error.  If I launch it from ARC there is no issue, if I launch it from the game file in the HDD directory there is no issue.

  5. DxDiag is in previous post, but why not again.

  6. Here is another log file, much longer than the previous, I let it go and did some other stuff, then came back.  Just to provide more information on what might be going on.




On 6/24/2018 at 2:58 AM, Wilder090 said:

Tried this, did not fix.  Still hangs up on “loading” after “connecting”. 

Is issue repeated now?