sold blueprint didn't get the GS ! and other issues

I’m having a few issues:

(issue #1) :I just sold  a blueprint for Phaser 17 for 125 GS and even though it disappeared from my storage, I didn’t get the gold, or…the notification that the deal went through…

 

(issue #2) in Corporate Earnings> win 5 battles (and receive corp. iridium), has been stuck on 4/5 for a week now…no matter how many games I win.

 

(issue #3) : in Ellydium Evolution hourly…"destroy (or help) 25 ships with thermal in PVP, etc…also has been stuck at 0/25 for over a week with many ships destroyed with thermal…

chat.log

combat.log

DeviceCaps.log

game.log

game.net.log

DeviceCaps.log

chat.log

combat.log

game.log

game.net.log

chat.log

combat.log

game.log

game.net.log

chat.log

combat.log

game.log

game.net.log

41 minutes ago, WhirlWindRider said:

(issue #1) :I just sold  a blueprint for Phaser 17 for 125 GS and even though it disappeared from my storage, I didn’t get the gold, or…the notification that the deal went through…

Contact to support please

 

42 minutes ago, WhirlWindRider said:

(issue #2) in Corporate Earnings> win 5 battles (and receive corp. iridium), has been stuck on 4/5 for a week now…no matter how many games I win.

 

(issue #3) : in Ellydium Evolution hourly…"destroy (or help) 25 ships with thermal in PVP, etc…also has been stuck at 0/25 for over a week with many ships destroyed with thermal…

Please make separates bugreports for other issues. Read this manual please 

 

Probably not a bug.

 

Here’s why.

 

When you send an item to someone, it will disappear from your inventory until it’s accepted and after the trade is made.

You set the price for Phaser 17 Mark 5 blueprint - 125 GS. Since the deal didn’t go through, it probably expired after 15 minutes, but the item should be back as well.

If that’s not the case, then the trading bug is back again. I reported this issue and it got fixed several months ago.