Shadow Textures Solid Grey After 1.2.5 update

Started playing Star Conflict again for the first time since OBT and it’s been working great for the last two weeks. Love a lot of the new features. So far, I hadn’t had any issues. The Linux client has been stable and faster for me than the Windows client. However, today’s update gave me a texture error that makes gameplay really difficult.


My OS: Ubuntu 15.10, x64, Intel Core i7-2630QM CPU @ 2.00GHz × 8, GeForce GTX 560M/PCIe/SSE2, Using NVIDIA GF116M Driver version 352.63 (tested - was working great until today), 203GB Partition with 35GB free


As you can see in the attached screenshot, all of the shadow textures are grey. If I move my ship into the shadow area, it turns grey also. Can’t see anything inside the shadow area - no contours, holes, anything - which makes navigation nearly impossible minus the fact I kinda know where some things are already. (Still, not getting into that vent in Fire Support)


The entire log file is attached. The only things I notice are this:



12:44:56.811  WARNING| frame 81 gameGlobals.frameTimeReal is too large (0.220103)


which happens many times throughout


Also this:



12:46:48.478    ERROR| Exporting texture to file is not implemented!!


And lastly this:



12:50:08.294  WARNING| Client: received Entity sync notification #0 for entity with netId 4557, but entity doesn’t exist(def ‘SpellAuraEntity’)


There was also a UI error but I doubt that has anything to do with the shadows.




Not sure if there’s anything I can do to fix this myself or if I need to wait for a patch. Really itching to play some more (been playing every day since I got back) but this is really throwing a wrench in that.


Thanks for the help.





[game.log](< base_url >/applications/core/interface/file/attachment.php?id=10299)

I encountered this bug as well. I’m on a mac client, and the same thing happened. My bug report:


Doombot is saying it is probably related to the video driver. But in any case, now it is confirmed that it likely isn’t a problem with our computers, rather something with compatibility with Linux and mac clients.

Same bug. Ubuntu 15.10, Notebook Lenovo E440.


k-zabello@kzabello-ws:~$ lspci | grep 3D
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)


game.log attached.

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=10302)

same here, it comes with the update… please fix it fast! anyways… no more server problems! nice so far^^ and pls fix it it is very difficult to play like this, for me it is a piece (maybe half) of the map

nvidia 650 gtx opengl supported

Same problem here, makes the game near unplayable.

Can’t see anything in the lower half of the map, same effect as OP’s screenshots

same here on slackware    nvidia


Well, of course Star Conflict was running from Steam fine but with the textures problem, so this morning I decided to try running it from the terminal to see what the outputs would be. So, here’s what I tried this morning - to no avail:


I first tried running Star Conflict this morning by navigating to the Star Conflict directory through Steam, opening the terminal there and then running “./StarConflict -mode:fullscreen -resolution:1600x900” it was giving me the error: “./StarConflict: error while loading shared libraries: cannot open shared object file: No such file or directory”.


Curious, I then went to the /usr/lib/ directory, sure enough, there was no “libcurl” anything in that directory.


I then went to synaptic to see if I had it, and I did - both the x64 and x32 variants.


Knowing this, from the /usr/lib/ directory I ran “find . | grep curl” which gave me two locations within the this directory, one at " ./i386-linux-gnu/" and one at " ./x86_64-linux-gnu/".


I didn’t know which one Star Conflict would be looking for so I chose to make a link to the 64bit one with the command “sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/” and then ran “sudo ldconfig”


Woops, my mistake. Having done that, Star Conflict gave me the lovely Christmas error “ wrong ELF class: ELFCLASS32” (Guess that’s a plus since I haven’t got to fly any of the Christmas specials so far)


So, apparently Star Conflict is looking for the i386 lib. No worries, I removed the simlink with “sudo rm /usr/lib/” and then created a new simlink with “sudo ln -s /usr/lib/i386-linux-gnu/ /usr/lib/”. Yay, now I had that libcurl problem taken care of!


But, uh oh, now I had a new error when I tried to run Star Conflict: “./StarConflict: error while loading shared libraries: cannot open shared object file: No such file or directory” Mneh…


But to me, this actually sounded like maybe it could be something with the graphics problem since it’s the Simple DirectMedia Layer (SDL) - so I go to Synaptic and check - sure enough, I don’t have it installed. So I then install both the " libsdl2-2.0-0" package and the " libsdl2-2.0-0:i386" package.

I then try to run Star Conflict again, and it runs! Yay!


But… ugh… no good. Still the same graphics errors from before. No shadow textures anywhere I fly to. :fed014:

Yes–I’m having the same problems–posted several other places here–Debian Sid (all updates current) nVidia beta driver 358.16 using SLI 760 Ti cards. Please contact me if you need more information…I do Debian debug work.


I added my game log also…


Added 20-12-15: I just tried to play Shadowy Trace for the first time after the update & it’s basically unplayable…only way I could at all is because I’ve played it before & kinda know where things are…log for that time is game(1).log

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=10308)

[game(1).log](< base_url >/applications/core/interface/file/attachment.php?id=10314)

After the last game update’m having trouble viewing the the gaming environment in pve or pvp mode, since removed the game and downloaded it again, did the same with steam, cleaned the cache linux (ubuntu 14.04), I have other games in steam, but them I’m not having any problems, since removed the graphics accelerator card and used other and continues with the same problem, I have not changed the OS, but I find it a bit exaggerated,


Intel® Core™ i5-3330 CPU @ 3.00GHz × 4 / 2x8 DDR3 Corsair 1600 / GeForce GT 640  Driver version 352.63 (tested - was working great until today) / 120GB SSD / 2TB WD / Linux x64 14.04




Captura%20de%20tela%20de%202015-12-22%20 Captura%20de%20tela%20de%202015-12-22%20

Problem fixed (for me at least) in the last update.



Yes–The update looks like it fixed my textures problem–Just played Shadowy & it looked good.  THANKS DEVES!!!


The only thing that I can see is the planet in the background in Empire Open Space is half textured & half black—but that is not affecting gameplay in any way…just a cosmetic flaw.

Hello, the update fixed my problems



congratulations Dev’s

Yes. Confirmed. Corrected with the last update. Thank you for the fix.