Selena Galo´s mission "All-rounder" broken?

Heyas!

 

First post to this forum so yeah, I´m a newbie :facepalm:

 

Can someone please tell me how I´m supposed to complete Selena Galo´s mission “All-rounder”. She tells me to equip a ship modifier from my warehouse (modification II) or better. What does this mean exactly? I have installed some Mk. 4 upgrades (purple colored) to several of my ships but this mission just doesn´t complete?

 

I have also tried to buy some Tier 2 basic equipment and installed it to my Tier 2 ship but that does´t help either.

 

So what am I doing wrong or is this mission simply broken?

 

Thanks for any help in this matter!

Can you make a screenshot of the mission window?

Ship modifications are the passive slots.

Thanks a lot for your answers! :slight_smile:

 

Here are two screenshots. One shows the mission I´m referring to and the other shows that I have installed a MK.2 upgrade to one of the passive slots and up to MK.4 to other slots. Mission still does not complete.

 

post-244138-0-54483700-1389379990.jpg

 

post-244138-0-58641400-1389379992.jpg

 

Yep it’s bugged then. Throw a message in the bug report section.

its not bugged.  Its asking for an upgraded T2 mod, badmofo the ships in the screenshot are T1

 

just upgrade one of the mods on your T2 ships

Oh… right…

I modified one Tier 2 ship and after that mission completed. :slight_smile: I just didn´t figure out that Tier requirement from the mission briefing.

 

Thanks a lot for your answers!

Just a tip badmofo, save your GS for t3 and above :slight_smile:

I also cannot complete this one, I’ve installed a MK.2 passive upgrade (for the CPU, and the hull) on a tier 2 and tier 3 ship and nothing happened. I tried various other ships, wasted a lot of money but still nothing… any suggestions?

I also cannot complete this one, I’ve installed a MK.2 passive upgrade (for the CPU, and the hull) on a tier 2 and tier 3 ship and nothing happened. I tried various other ships, wasted a lot of money but still nothing… any suggestions?

 

This bug was supposedly fixed, please attach your game logs and I will foward it again to see what happened.

I will do so gladly but I need some help how to do it. How to create a log file?

Ok, read about it, my log files are in the attachements.

 

Thank you for your time and your help.

[chat.log](< base_url >/applications/core/interface/file/attachment.php?id=7496)

[combat.log](< base_url >/applications/core/interface/file/attachment.php?id=7497)

[game.log](< base_url >/applications/core/interface/file/attachment.php?id=7498)

[game.net.log](< base_url >/applications/core/interface/file/attachment.php?id=7499)

Ok, read about it, my log files are in the attachements.

 

Thank you for your time and your help.

 

Ok thank you, forwarded.

Any response from the devs?

The mission says “from the warehouse”, so make sure you actually did that. Upgrading a module in place (while installed on the ship) does not complete the mission. If you did upgrade in place, simply remove the module and then put it back and it should work. I don’t recall whether you have to do it on a federation ship (it’s a fed mission isn’t it?) but typically you have to complete missions on ships of the faction that gave it to you.

If that was not your problem then there might indeed be a bug - the only response you might get is a line in some future patch notes mentioning the fix.

The mission didn’t say “from the warehouse”, but a minute ago I uninstalled the module, then put it again and, finally, mission complete. I’ve done that several times before and it didin’t work, no idea why it works now, but it does. Thanks everyone for the help :slight_smile:

The mission didn’t say “from the warehouse”, but a minute ago I uninstalled the module, then put it again and, finally, mission complete. I’ve done that several times before and it didin’t work, no idea why it works now, but it does. Thanks everyone for the help :slight_smile:

It does say, there’s a screenshot above. Anyway glad I could help.

Guess this can be closed. :wink:

In the updated version of the game the quest does not mention the warehouse :wink: anyway, glad it’s ok now, thanks.

In the updated version of the game the quest does not mention the warehouse :wink: anyway, glad it’s ok now, thanks.

Fair enough, checked and indeed it now says:

 

Open the Equipment tab, choose a slot and install a ship modifier Mk.2 or better.

There are ship modifiers for engines, capacitors, hull, shield and CPU.

tbh they should just fix the mission in a way that upgrading in place works too