Sector Conquest failed to run

I had ranks r7,8,9 in the queue.
I tried to get in solo. Clicked the button and it said I had the wrong rank ships.
I tried again and got the same message. I switched to r10-12’s. Got the same message.
Went r13-15. Same message. Went back to r7-9 and the button was inactive.

A corp mate got in on r10-12 with a group.
Another got in solo 7-9.
I got told I had the wrong ships.

You folks really need to write definitive rules for how sector conquest works.
Not a player guide. A devs guide.

To have a holiday event with extremely limited access like this current stage is ridiculous.

BTW there were no announcements that it was starting other than the initial declaring message.

As for logs, tell me where they are in win10 and I might try to send them. I have searched.
I hope I can’t duplicate it but I have to wait several hours to try.


Is there ship Dart in your setup?

we had same issue with a Gargoyle ship, we took it off and it all worked fine

styx, archon and a crus-s.
I don’t have dart or gargoyle.

EDIT: I took the dag t’nith launcher off the styx  and was able to get in.

Further edit: Why can a dest have an alien crystal tech weapon but a frigate can’t?



Try to repeat after next update