Not getting daily rewards

Since the latest patch i am not getting the daily rewards of containers, i was on 5th day login when patch was applied and should have got a adventurer pack, but it just went to the store and wanted to charge 350GS , i waited and nothing happened, tried closing and reopening , nothing, the next day, back to day one login, directed to store, nothing , closed reopened, nothing , played a bit of game, then the green bit in the store icon lit up, and it then said redeem on a rusty container, day two , nothing and still nothing. Any fixes in progress? and can you credit rewards?

This has been happening with any loot recently. Occasionally after battle or completing a mission it will take a really long time for the server to return that you have received the item(s). The server probably got stuck when you accepted the free container badge and it is holding it. Just sit tight until you get it. I’d suggest staying logged in, but that may or may not solve the issue.

It took about 2 hours of battles for some upgrade kits that I received to be applied to my account yesterday.

Same here. Last two 5 day rewards never arrived.


Today, around 11am central european time I logged in, pressed “collect”, then nothing, no notification. got to store, and nothing to redeem.

I’ve re-checked the store a few times during the day to see if it would pop up, but have still not received my container. 


Last time was before the patch with the reward change. Same thing, logged in, pressed “collect”, then nothing. no notification, no popups, no rewards (as far as I know)

Ok, so when I logged in today, just now, I pressed “collect” on my 1 day reward. Got no notification. But when I got to the shop, I could redeem an adventurer pack (5 day reward I didn’t get yesterday I guess), but there was no Rusty Container to redeem.




so far i collected rewards for day 5, 1, 2 and now on day 3 it is bugged and it wont let me redeem for free.

We are aware of the current issues regarding the rewards. We already found the cause of the problem and we are working on it.

I got al that useless rewards on days 1-4 but now when I want my 5 day reward which is the best I didn’t get it. I hope you fix it and I get my 5 day reward and not again 1 day and so on…

Same here. Got all those minor rewards before and the only one that could make a little difference (5th day) is nowhere. Sigh.

For three days in a row I do not get the FREE container and i on DAY 5 wich is the only one interesting


logs, logs, logs needed at every issue