[NB](assault) herc, herc rage and deimos missile bugs

piercing missiles seems to be ‘stuck’ to a single type…


not sure what this is based on, but on my T1s imperial assaults they are stuck with Mk3, and on the demois (T2) it’s Mk1 piercing.


cannot select any other options. the other missiles types, EM and standard (thermal) have Mk1, Mk2, Mk3 and permium options.


actually. it’s a bit more complicated than that.


my axe-x appears to be stuck with Mk3 only as well.


machete AE has no piercing option at all. (just bought it to test)


seems like i broke something lol.


tried restarting the client. no worky.




http://i.imgur.com/fnYxDG8.jpg deimos standard options


http://i.imgur.com/VPgBnI7.jpg herc rage


http://i.imgur.com/wRWGuLG.jpg herc


http://i.imgur.com/5ueQOIf.jpg machete AE (no piercing)

My missiles work just fine on those ships… Tried reinstalling?

My missiles work just fine on those ships… Tried reinstalling?


rofl :beee:


steam passes integrity check.


in any case. i don’t think it’s the client… i thin something is genuinely ‘stuck’ preventing me seeing anything but the piercing missiles i had at a given point.


i’m pretty sure if i bought more ships, they would also be missing the piercing option completely.


basically all of my fighters are stuck (all the axes as well) on the piercing missiles they had equipped. and no other options are available.


it seems T1 only Mk3 piercing, T2 only Mk1 piercing.


when i try to buy new ships, they have no piercing options.

Same deal with me on my Machete line. But in my case it’s all stuck to Mk.I’s Kinetic.

i could install the client on my other workstation to test. dont really feel like reinstalling. hmm i have to install steam too. grr :\

T2 Mk1 piercing missiles have now magically appeared on the Machete AE. when i first bought it, there were no piercing missiles at all.


edit: 1 hour later now, the piercing missile option is once again gone from the machete AE ;o

My T2 Deimos 2 piercing missiles are this way.  I’ve noticing nothing for T1 or T3.

You guys just keep emptying the store of those missiles I bet, That is why they are not on the shelves :P 

But I have seen it in the lower tiers as well some time ago. Though never in T3/T4/T5.

You guys just keep emptying the store of those missiles I bet, That is why they are not on the shelves :P 

But I have seen it in the lower tiers as well some time ago. Though never in T3/T4/T5.


Signed. As lang as you have Unit of Rocket, you will refill them over and over again. T2 Fighters do not have Kinetik Missiles as Equipment.


T1 only has Thermal

T2 Thermal and EM. If its a Tackler, they do have Slowing too.

T3 Full selection. Command with Ion now and Guships with Firestorm.

well then there is something wrong, because kinetic mk1 keep showing up on my machete AE (t2) at random times… and other times they are not there… they are on the deimos (T2)…


and my T1 are locked to a specific Mk of thermal missiles (Mk3), with others not being available, as you can see in those screenshots, something is odd :\

When they changed the weapons around and auto-sold weapons you could have anymore, they missed a few.  Since it’s been reported now, it’ll probably be gone in the next patch.

Equipment Wipes will not be done in the near Future.


T2 does not have Kinetic Misiles. If you still have some, or got some by Ship purchase, they are dumb Prefits. Otherwise i do not know why there are still in. 0.9 Wiped all Rockets and Weapon Mods.


If you sell that last piece you have, they will dissapear.

nope, i sold the last one and they re-appeared… then they disappeared an hour later… then reappeared again… on my machete AE


on my deimos T2s, as i said… they are always there… even if i sell the last one, i always have the option of Mk1 kinetic missiles on T2… no Mk2 or Mk3 though.


still doesn’t explain why my T1 have no Mk1 or Mk2 missiles. only Mk3…


btw… what you are saying is that if people had Mk3 kinetic before… then they can have them forever on their T2s as long as they don’t sell their last one?


does that make any sense at all? this is an exploit…

ok i think i know what i happening now… and this is a technical exploit… you need to delete all kinetic T2 missiles in that case…


the kinetic probably reappeared on my machete after i removed them from my deimos.


so as long as you have 1 unit, you can swap it between any T2 ship and keep it forever…


now that i’ve sold them all, i have no more kinetic on T2.


also, my T1 thermal options Mk1, Mk2 appeared again…


i think this happened when i received a reward with premium T1 missile. it must have fixed whatever the error was from dispaying the Mk1 and Mk2 as well…


the other thing that might have fixed T1 is selling all my T1 missiles.


so T1 standard are bugged, and T2 kinetic are exploit.

There’s a difference between selling and removing.  When you remove it, your ship just doesn’t have it.  You can put it back on for free.  When you sell it, you no longer have it in your warehouse so you have to buy it again.


I guess in the next patch my T2 armor piercing missiles will disappear.

yea pretty much. so they removed all T2 kinetic missiles from hangars, but they didn’t remove them from people’s ships.


and the way missile resupply works is it just give you another copy each time.


so you can remove it from a ship you still had it on, equip it on a new one, and still keep it forever and keep swapping them around.


you also need to remove all T1 standard missiles, as i said there is a bug, and removing all of them will most likely fix it as it has for me.


edit: i just realized now. i didn’t expand the missile selection box on the T1s (in the screenshots)… but if you expand it, the only option was Mk3…


sorry, i have no way of reproducing it now, and just took those screenshots in a hurry in sequence, forgot to expand the dropdown…