Most of the in-game texts are almost invisible

For some time most of the in-game texts changed the font color (or something like that) so they are almost invisible. This includes: modules and weapon descriptions, ship prices, container prices, text in the drop-down menus of the game options, crew implant descriptions, amount of synergy on the current ship; in storage - description text is visible, but only if the item/module/weapon is not selected. This is happening both on the Steam version and the version downloaded from the site (both installed in different directories)

This is going on for several months and i’ve been struggling since to fix it. The time this happens coincides with two things: my old GPU died and i had to replace it, and the game had an update (unfortunately i don’t remember which one).

What i tried so far:

-Uninstall the game and re-install it. Also tried when uninstalling, finding every possible remnant of the game on the pc, deleting it, restarting the pc and then re-installing. (Also tried installing on another Drive)

-Deleting GPU drivers and re-installing them.

-Played with all graphic options in the game, no change whatsoever.

-Installed the game on another PC and logged in with my username- no problem, everything is visible and readable.

The only thing i thought of, but didn’t try, is re-installing the windows, but i have so many programs to set-up in that case that i’m keeping it only as a last resort.

I noticed the game logs are full with a lot of warnings, i’m also attaching screenshots, the logs and dxdiag

Hope a solution can be found fast. Thanks!








Provide a full DxDiag log.

Here it is


Screnshot from May, 3. Logs from May, 4.

Logs for screenshot needed.

Sorry, didn’t notice they were with different dates when i uploaded them. Since the logs are gone, i’m uploading screenshots, logs and dxdiag from just now