Major Bug: Custom Battle can be restarted, even before others have finished with their looting!

Bug report:

 

 

1.) Description of the problem, what happened?

Me (Koromac), as a Squad leader, have invited 3 of my friends in the Custom Battle match. (Tier V PvE - Captured Dreadnought, EU server)

We finished the 3rd round and we were at the looting screen. I ended it, before others or they waited.

I clicked on the Launch button again outside of Custom match again, while the others did not finish looting.

Game restarted, while the others most likely lost all of their gained loot, possibly daily purple spot as well.

 

2.) What did you expect it to happen?

I expected, that I will be UNABLE to START another match, or at least not, until the others have finished with their looting (looting spots), when they are returned to their hangar shortly after.

Squad Leader should never be able to start the match, until all members are finished and ready!

 

3.) The conditions during the situation?

Normal and smooth operation. No other issues detected.

Only condition is that the creator of such match (lobby), finishes the looting first or skips it and then he re-launches the match, before the others are done with the looting system.

When the next match starts, 30-60 seconds later, an error message appears. Will be shown in the screenshot 2. This is probably related, because I started the match, before others were ready for it.

 

4.) Further details on the issue.

5 second countdown is ineffective and it fixes nothing, nor it is meant to. I suggest, that you can change how close button operates.

Either make it available, when all players have finished looting, or when their looting time expires automatically. (might be time consuming)

The best option would be, to just disable the Launch button, until all parties are done with their looting and ready for another battle, but ONLY AFTER they are in their hangar!

You could only launch the battle, if other players, which are part of a group, CONFIRM IT.

Rewards gained from looting are most likely interrupted and are probably NOT STORED (admitted) in the armory of the affected individuals. (daily purple reward is gone on the 2nd try)

After re-launch, they just immediately start at round 1, even if they do now want, or need to. They cannot leave (exit) the battle in such case.

 

5.) Frequency of occurrence.

Always, or whenever the player rushes to start (launch) another same battle as soon as possible.

It could be caused intentionally or unintentionally.

 

6.) Logs + [screenshots](< base_url >/index.php?/topic/18799-how-to-takepost-screenshots/) or a video (Including a description of the issue, where to and how to reproduce it).

All necessary and relevant logs are provided.     

Screenshots are provided as well.

 

2 screenshots:

 

Screenshot 1: involved parties (match 1, shortly before I went into hangar (custom match) and press Launch button again)

2iiibf5.png

 

Screenshot 2: Error message, 30 to 60 seconds, after we started the 2nd (forced) match.

x1k68l.png

 

7.) If possible, the time when it happened. In this case we will be able to look more closely to the server logs. Also mention your time zone.

The exact time of this incident is visible from the logs.

Approximate time is on both screenshots.

Time stamp on both screenshots is around 15:39 and 15:41.

Time difference taken into account for my Country (Slovenia) is UTC+1.

 

8.) Information on the configuration of your computer (DxDiag).

It is provided. 

 

9.) The results of this [program](< base_url >/index.php?/topic/25324-info-connection-losses-high-ping-and-related-issues/) if the bug report is related to connection issues.

This issue is not at all connected to any connection issues.

 

10.) If the complaint is related to Sector Conquest, it is necessary to specify the location and time + timezone of the happening.

This issue is not at all connected to Sector Conquest.

 

 

 

Thank you, Skula1975.  :012j: