Invisible login screen. [NB]


The login screen.


Opening the game from Steam.

Ok, so I played the game for the first few days, had 0 problems. It was working great, I was having fun, it was a blast. I took a break for a couple days, and when I came back, I had this problem. Whenever I open the game, my hot bar and top bar disappear just like they would if the game was loading. After a few seconds, I can hear the music. But the whole application is invisible. I can click on my desktop and it will take me back there, but I can’t play if the game is invisible. I don’t know what I did to break it, but I’ve tried restarting my mac, deleting and redownloading the game and Steam, and no luck. Please help.


— Date: 2013-05-16 (Thu May 2013)


22:58:27.433        | //////////////////////////////////////////////////////////////////////////////

22:58:27.433        | //

22:58:27.433        | // Build: StarConflict (Mac OS X) (May 16 2013 11:48:00)

22:58:27.433        | // params: “-psn_0_249917”

22:58:27.433        | //

22:58:27.433        | //////////////////////////////////////////////////////////////////////////////

22:58:27.433        | 

22:58:27.488        | Failed to initialize Steam. Probably Steam client is not running.

22:58:27.488        | Preloaded 1 SStrings

22:58:27.605        | reset d3d device

22:58:27.763        | reset d3d device

22:58:27.879        | Number of audio devices: 1

22:58:27.879        | Audio device 0: Built-in Output


22:58:27.880        | Speaker mode: STEREO

22:58:27.880        | Speaker mode: STEREO

22:58:34.922 WARNING| ^1Cannot load ui resource load info from file ui/locale/english/textures/textures.txt

22:58:37.233        | Entity Defs hash 7F868C3B. calculated in 1.61 sec

22:58:43.109        | ====== starting level: ‘levels/mainmenu/mainmenu’  ======

22:58:45.031        | MasterServer_RequestServerStatus

22:58:45.032        | MasterServer_RequestServerVersion

22:58:45.032        | MasterServer_RequestNewsFeed

22:58:45.032        | MasterServer_RequestServerAddresess

22:58:45.032        | ====== level started:  ‘levels/mainmenu/mainmenu’ success ======

22:58:47.536 WARNING| frame 225 GPU wait time is too large (2.191417)

22:58:47.559 WARNING| frame 225 gameGlobals.frameTimeReal is too large (0.583735)

22:58:47.984 WARNING| frame 226 gameGlobals.frameTimeReal is too large (2.219660)

22:58:47.993        | MasterServer_OnServerStatus: status code 0, server status 1

22:58:48.000        | MasterServer_OnServerVersion: status code 0, version, my version is

22:58:48.001        | MasterServer_OnNewsFeed: status code 0

22:58:48.001        | MasterServer_OnServerAddresess: status code 0

22:58:48.110 WARNING| frame 227 gameGlobals.frameTimeReal is too large (0.424457)

22:58:48.181 WARNING| frame 228 gameGlobals.frameTimeReal is too large (0.126611)

22:58:48.587 WARNING| Custom memory managers gets unregistered not in reverse order of registering! (MM name: )




I am running a 2011 macbook air with OS X 10.7.5.

Hey, it’s been a while, there have been a few updates, and I still can’t play. What’s going on?

Hey there we have installed the patch that should’ve granted you the possibility to run the game.

Have you tried reinstalling/updating it again? 

Do you know of your Mac hardware in case if still doesn’t work? What video card it uses? 

Nothing new on my end after the last patch.The white bars covering the loading circle, the login screen goes black, thought the music still works. This was after the patch, but without a redownload.



Processor: 2.53 GHz Intel Core 2 Duo

Memory: 4 GB 1067 MHz DDR3

Graphics: NAVIDA GeForce 9400M 256 MB

Software: Mac OS X Lion 10.7.3 (11D50)

On windows, I’ve noticed that if I launch from steam but switch the app too soon, Star Conflict sort of hangs.  It continues as soon as I switch back.  Perhaps it’s related.