I have a(n) ********* server that is broke...

Anyone know what unexpected exception: “n must be positive” means? XC

What kind of server is it, and what OS is it running? Also, what are you doing with it?

It is a gaming server, running on a Windows XP PC. It is a dedicated host, so it just Honda sits there in the corner. I can tell you now that there aren’t any connection issues, because I run two servers side-by-side and the non-broken one works fine.

I was on it with a friend of mine when all of a sudden the host returned an insanely long error and closed its self. I have tried resetting the map and killing all entities and everything I can think of, but every time someone tries to log-in, the server crashes. It’s like it doesn’t suppourt people any more…

this is very vague. it is unclear which software you use, therefore the error message is unclear aswell.

clearly there is a variable called n, and it should be positive.

what it does depends on the program you are using.

I might as well say it, (because this IS an off-topic place,) that it is a Minecraft 1.7.10 Vanilla server. Though the fact that is Vanilla/modded means nothing in this case. I was playing on a Skyblock with my friend and the server suddenly died. I tried cutting out the Skyblock and pasting it on another world, but it killed that one too, as soon as I got within about 50 blocks of the island. So there is something on the island that has the variable “n” and it is currently negative. Though I have no clue what it could be.

well being java, it’s most likely calling random with a negative number; can be anything.

did you try googling the error with minecraft in it?

seems like a lot of people encounter this - possibly for various reasons.

one of them is e.g. vines growing down a void.

but i would ask that in a minecraft forum. anyway, exceptions are not “globally unique”, you cannot ask about an error message without supplying the software in context, which is the main thing i wanted to tell you :slight_smile:

I have searched extensively and no solutions have anything to do with my problem/are about a mod/modded server.

Here is the latest crash log: 

(and once again; I can’t copy and paste ANYTHING to the forums, so I’ll just put a link that I had to TYPE MANUALLY here:)




In this load’s case, it crashed while loading the world, but it crashes with the same message when you log in to it, so I don’t see the difference.

do you have a hole in your world where vines can grow down? something like that would trigger this.

okay looking at the stacktrace, the problem is somewhere along generating the world decorations; negative n means, the data to generate this is somehow unusual. a typical problem can be a hole in the base of the world, so height coordinates get negative.

since it’s bukkit, which is known for child labour in the plugins, you might also want to deactivate some of them, or maybe one of them destroyed your world.

i would do a transplant, and if you know exactly where the problem seems to be, remove that part of the world.

more i cant say, maybe you find a minecraft expert who looks into this.

I just removed the village portion of it and copied it to a new (pre-generated) world and made sure that biomes were not copied. Loading it as I type…



OK! So it loaded up fine and I could freely explore the world with no errors!!! (yay!)


When I died from random suicide bomber It crashed again with error “Ticking Entity”



*EDIT* again

Logged in again after restart and it works fine. Going to proceed with the formal re-introduction of the world’s entities and see what happens.

Given your minecraft server’s proclivities to crash, I’d go as far as to say that you probably have a broken mod on there somewhere. Try running without any mods, and see how far you get without crashing.

lol yer a bit late. I got it working (for the most part) again. and I did all the tests currently with a vanilla server. once it started working again, I put the original plugis folder in and it works like a charm\