I cant check the "Enable Oculus" checkbox in the options menu



I recently received oculus rift DK2 and tried to run star conflict with DK2.

I can see the menu and checkbox in the settings menu, but it seems disabled and I can’t check that checkbox to enable the rift mode. 
All the configurations are there, I just can’t access it. ( clicked but no changes in the checkbox )

Is there some other settings or shoud do some hacks in order to enable it?

Any helps would be really appreciated, I really want to play star conflict with dk2!




  1. I tested this with my macbook pro retina (late 2013, OSX 10.9.4) and have no problem testing other rift demos.

  2. it’s in extended mode. (mac version of oculusconfig util only supports extended mode for now)

  3. switched dk2 display settings between primary <-> secondary monitor, still no joy. 


* attached screenshot and game.log, if they helps.


[game.log](< base_url >/applications/core/interface/file/attachment.php?id=8206)

please dont use capslock titles - title updated

Hi stm,


its probably not much help but I am currently playing SC on my iMac in bootcamp windows. Its working flawlessly when in extended mode, also with the latest oculus runtime. done anything in MacOS yet as I dont use it at all. (just for the ocasional firmware update).

be sure not to disable the oculus service anymore as was needed pre version 1.0.


my 2 cents.

@gekaler, sorry. It was my mistake. Just copied the title from the one I wrote on the steam forum which I couldn’t get an answer.


@Codex6666, unfortunately, I don’t use windows and oculus service is keep up and running… but thx for the advice anyway.

With today patch we support DK2 on OS X - check it out.

Some additional info can be found here http://steamcommunity.com/app/212070/discussions/0/34093781571047033/#c613937306561525548