Game slows down when switching to another program



I’ve some strange bug. I think I found what triggers it, but I’m still not sure.


So, the description:


I enter MatchMaking (doesn’t matter if PvP or PvE) and switch to another application (Firefox, LibreOffice, Teamspeak,…) when I hear the sound that a game has been found/created, I switch back to the game. Sometimes everything is fine but recently this issue creeps up nearly everytime. So, after I switched back to the game, everything is ‘slow’, the clock showing the seconds/miliseconds is not rendered ‘fluently’ anymore and when I finally enter the game it has something between 12 and 20 FPS (much less than usually).


I think the problem only arises when I’m out of the game for more than 30 seconds, that’d explain why it happens so ‘randomly’ (previously I was able to play for at least 20 minutes until it happened, now it happens nearly every time).


If, after the match, I restart the game and join another match without switching to another application, everything is fine.


System stats:

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cypress XT [Radeon HD 5870]
           X.Org: 1.15.0 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1200@60.0hz
           GLX Renderer: Gallium 0.4 on AMD CYPRESS GLX Version: 3.0 Mesa 10.1.0
CPU:       Hexa core AMD FX-6350 Six-Core (-MCP-) cache: 12288 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm)
System:    Kernel: 3.13.0-13-generic x86_64 (64 bit)

                 Desktop: Gnome 3.10.4 Distro: Ubuntu 14.04 trusty

Memory:   7951.7MB

There is a slider in options ‘Limit FPS when minimized’, right after max fps slider. Default is something about 30, try raising it up. Maybe it bugged.

Are you using Linux?  I am having the same problem with Windows 64 bit.

There is a slider in options ‘Limit FPS when minimized’, right after max fps slider. Default is something about 30, try raising it up. Maybe it bugged.

tried it, didn’t work.


Sorry for the late reply. After the latest patch I didn’t experience the bug for quite some time until today. I tried alt-tab mutliple times without success. I changed the FPS limitation you suggested but that didn’t do anything either. (Maybe the game needs to be restarted? In that case it should not happen to me in the future).


For reference: The game is currently using ~680MB of RAM and 10% of CPU.


A fresh started SC uses ~490 MB of RAM.


after one match the game is up at ~600 MB of RAM. Seems some assets are only loaded during the actual match. So 680 MB is okay.


@Engle yes I’m on a 64 bit Linux distribution.


I just found out that the game seems to override the logfile when restarting it. For people looking for it on a Linuxoid system, you’ll find it in ~/.local/share/starconflict. There are several logfiles in that directory, but I guess the game.log is the one to look at in case of problems. There is also an ‘exception’ subdirectory but that’s empty in my case.

ok, had the same thing happen again.




I looked through it but couldn’t find anything obvious. The stutter appeared when the last game loaded. I switched back to the SC, noticed it immediately and exited the game shortly after.

interesting. The bug appeared just yet. But I did not once switch between applications! RAM is at 589 MB, so that’s not the problem.


Game log:

It hit me again today. I had the game running for ~5 minutes (didn’t find a game). After ~2 minutes I changed my searchtype from Matchmaking to Mission, after 2 more minutes I got into a match and again the FPS decreased immediately.


Since I didn’t want to leave the game, I decided to tinker around a bit. It seems that if I change the resolution, click ‘apply’ and then change it back, the FPS count is back to it’s normal level! So at least I’ve a workaround now…