Fatal error. Direct3d device is lost. Crash.


When I launch the game, it crashes upon reaching the menu, and the log gives me this(near the end, obviously)

19:24:25.153  WARNING| frame 937 gameGlobals.frameTimeReal is too large (0.228795)

19:24:29.446  WARNING| frame 990 GPU wait time is too large (3.970358)

19:24:29.690         | reset d3d device

19:24:30.134    FATAL| d3d device reset failed: Direct3D device is lost


I don’t understand this, as I have all my hardware installed correctly, am well over the required specs, and I have my directx up to date. Anyone have a fix?

EDIT: This log was found in the exceptions folder, and the d3d device is lost error has only happened this once. All the other times, I get the problems of frameTimeReal is too large(as seen in log excerpt) and/or GPU wait time is too large. Any help would be appreciated

I don’t know if it’s the same case, but I restarted Steam and it worked.

Try to search Exception in the game folder.

I get this error when I’m launching another game at the same time as Star Conflict (i play something else while waiting for queue). So it might be some other application that is using the video card for you also? 

Try to search Exception in the game folder.

The log excerpt shown here is from the exception folder, and is the only file in the exception folder. The other logs are all crashes due to gpu wait time is too large and frametimereal is too large.

I was also wondering, seeing as this is a crash on startup and I can’t access the options, is there a file that I can edit to get the game to launch in windowed mode, so it doesn’t simply black screen and sound loop?

Please, will attach zip archive with Logs and Exception folders on your PC

Here is an upload of my entire StarConflict folder in the My Games folder.

[StarConflict.zip](< base_url >/applications/core/interface/file/attachment.php?id=8824)

Will add that the game crashes every single time I launch it, and that this is not a onetime thing.

Try to start (in the game folder)  game.exe  with key  -d3d9ex

Just a question, to add a key, would I run the program using a batch file with the key in it? Or if not, how would I run the program with the key?

EDIT: Just tried running with batch file as administrator, did not work.

EDIT: Attempted the -d3d9ex key, which did not work. Also attempted reinstalling my drivers for literally everything to no avail

I don’t know if it’s the same case, but I restarted Steam and it worked.

Worked for me.