[F]Suppressive Fire contract bugged?

The contract “Suppressive Fire” which is available on Federation’s Armada from reputation rank 10 on, is bugged I think. It says I have to assist in 40 kills while boosting my allies’ firepower. Well, that’s what I have been doing with the Valkyrie system since then. It doesn’t work/count my assists in battle.


I tried this with two different systems (on my Wolf-M):


  • The Experimental Valkyrie System

  • The T3 MK.I Valykrie System


Now my question: Is it really a bug?

Or do only assists in a winning battle count?

If not so, it doesn’t work.

All of your equipped ship is T3 or higher?

Last time i did this contract it worked fine.

Yes, my ship is T3… And I have the Valkyrie System…

Still didn’t work a single time. Not one of my assists in battle was counted for the contract. Don’t know why.

Same here i am hoping the server restart fixes this.


*T3 Frig


Drone fleet and Path to victory are not registering anything

Safety First has only registered 1/5 kills and wont progress any further


Will add as i try others.

Server restart did not fix it :frowning:

Sorry to asking again but maybe we don’t understand each other:


ALL of your equipped ship is T3 or higher?


When i bought my first T3 ship and get contracts for T3 i dont get rewarded for doing it because i had my T2 ship in the other slot (at that time the only way to clear a slot was to change slot type for about 100k cred…)

Ok cheers ill check that

Yes what Mowa Said Works

Cheers for that buddy !

I have encountered the same problem a couple of weeks ago.

The solution was to change the valkyrie system to another slot (example: My valkyrie was in slot No. 3 and changed it to slot No. 4).

As result, the contract works fine, only some ships have bugged module slots.