[F] Ship flies in 'circles' w/o kb/mouse input

Charactername: - Aryc

What did you expect to see: - When no keyboard or mouse input is entered, ship should idle (fly straight, or just not move if there is no thrust).


What happened: - Ship continues to fly as if there is persistent kb/mouse input so (in most cases) the nose moves around in a circle (both clock wise or counter clockwise) while the ship moves forward. In some cases, the ship is stuck doing loop the loops. This can persist after respawn or changing ships. Sometimes when using free look, the ship will return regular control. Sometimes free look does not correct the issue. There is also a delay when using the keyboard and mouse. Reticule follows the mouse in realtime, but ship does not respond until ~1 second. Using active modules or firing main weapon or missile also have a 1 second delay.The ship does accept further keyboard input, but it lies ‘on top’ of existing movement so I had to constantly correct or account for the existing ship movement and I could not bring the ship to a complete stop.


What was your last action: - Ship would always ‘start’ the battle under full control. Issue would occur typically after flying in any direction other than a straight line and persist through the rest of the battle.  

Is the bug reproduceable, if yes please describe how to reproduce the bug: - I was able to reproduce it for the past 2-3 days. At first thought it was just because I started flying interceptors, but my brother showed me that it wasn’t normal for my ship to ‘not’ fly straight. He recommended I restart Steam, Star Conflict, and my computer. Issue persisted. Tried to change keybindings for Mumble and Star Conflict in case it was related (only run SC & Mumble at the same time). Finally reinstalled my wireless mouse software, reset it, and it (appears) to work for a few battles last night.

Please attach at least one screenshot or make a little video of the issue: - didn’t think to get screenshots/videos while it was happening. It was kind of funny trying to shoot stuff w/o control of my ship. Do not have ability to capture video :(.

Attach the game logs from the session to your post(Only the logs from the session where the bug occured. The logs are located on

My Documents/My Games/Star Conflict/logs): Will try to find these when I am at my game cpu.


What are your system specs: - using wired logitech keyboard (usb) and wireless logitech mouse (usb wireless unifying tech)



I just wanted to report this error. I don’t ‘know’ that it’s actually related to SC or my mouse software (not sure why it’d interfere with the keyboard input or introduce delay), but couldn’t find a report like this and want to report it in case other folks run into it.

It is something Interceptors do under slight lag conditions.  

It happened to me consistently when the a cable broke in Singapore and Australian ISPs were effected.  

Its intermittent now.  


A fix is to switch to Expert Mode under settings.  


It is far from ideal as I’d rather be playing with Basic.  

Sad to see this is still an issue.  


It took me and my mates a few days to figure out how to fix it.  

Weren’t as many of us playing by the end of it.  

It is infuriating trying to aim Micro Warp while the ship is rotating of its own accord.  

I’ve attached the game logs from the 3 sessions I had.


The first one I had the issue immediately.


The second one was after I restarted star conflict and my computer and it persisted.


The third one was after I no longer experienced the issue.


I forgot to note that the mouse lag was also noticeable when looting - there’d be a delay where I needed to hold down my mouse button longer than expected to complete the loot bar.


Werewomble - thanks for the response. I first noticed this in an interceptor (recon and covert ops) and I wasn’t able to microwarp b/c the act of flying in circles usually prevented the microwarp engine from even kicking in. I do not have any battles /w a recon interceptor in the above logs.


Finally, this issue was present in both my frigate and fighter ship after I respawned. It also occurred when I first spawned as a frigate or fighter first, but most often as the interceptor, then fighter, and least often as frigate (but then I don’t usually do fancy flying in the frig.)

[2013.04.30 21.33.46.zip](< base_url >/applications/core/interface/file/attachment.php?id=5899)

[2013.04.30 22.16.13.zip](< base_url >/applications/core/interface/file/attachment.php?id=5900)

[2013.04.30 22.39.22.zip](< base_url >/applications/core/interface/file/attachment.php?id=5901)

May be the same issue as [http://forum.star-conflict.com/index.php?/topic/17675-fship-spins-around/](< base_url >/index.php?/topic/17675-fship-spins-around/)


I have the 5% Jericho speed implant. I have not yet tried expert mode, but I have not been able to reproduce. If this occurs again, I’ll try to remember to get ping info.

This only happend to me once. My ping was so horrible bad that my ship was uncontoleable (~500). Also had a quite long delay for input.


This is a connection issue, created by to high ping. Ping and connectivity can be shown by pressing F11 mutliple times. It is shown in the lower left corner of the screen then.

well happens almost all the time. BUT not when i hit esc … then i can go backwards or stop.

sometimes it happens a few seconds after the begining of a game after using afterburner, a couple of times it reverted to normal after 10 minutes of game.


expert or basic mode, on all the ships … my ping is between 30 & 134.

btw during a game i had NO keyboard at all. not even escape key :slight_smile:  and sometimes i quit game, restart and feels like i have fewer problems.


i really like this game … but when it comes to play ecm … you just need to stop moving to manoeuver.

related to controle input. Unplug all other devices except mouse and keyboard.


otherwise, give us a DX Diag file from your system

This has also happened to me just then, purely in my interceptor though, it either does circles or the ship just nods its head, it’s both a blessing and a curse in combat though.

something like [this](< base_url >/index.php?/topic/19797-o-inertia-issues/?hl=inertia)?


well if you’re in the same boat as I, learn to fly frigates coz I havent been able to fly my inty eversince.


switching view to expert helps some if you still insist.