[F]Lost all my "Hacked Firmware" items

So yesterday I thought I’d spend some of the galactic standards I got from the steam deal and bought 10 hacked firmwares for 5 000 galactic standards.  Which should have lasted me 50 battles (states its 5 battles each on the item). I did about 10-20 battles before I called it a night. And today when I log in I have 0 hacked firmwares left.


I’m not impressed on how the real money items are being handled in this game so far. We have no way of knowing if the steampack items work (except when you get less rep then you normaly would, cant loot x6) or not since its not stated anywhere that you have an artifact scanner or if the VIP bonus is active and now this.


I tried relogging after the first win since the steampack items are bugged and dont work unless you relog after your first win…but no no hacked firmwares.


edit: Also tried buying one more hacked firmware to see if the others would show up. That didnt work either. Only made me have a hacked firmware for 5 battles.

All lost boosters have been refunded. If you are still missing your boosters, contact the support via the in game button.