[F]Did anyone else ever experienced this? (Dancing Ship problem)

I have downloaded the game today - and it is great. Held me for hours playing.
But one thing is increasingly annoying me - some kind of weird, involuntary, persistant wonky bouncy movement of the ship.
The propulsors activate randomly, making my ship dance around. I can barely aim.
It does not seems to be any command i am sending - in fact, i have already put my hands off keyboard and mouse just to see it. It just keeps doing that “dance”.

Two other things i have noticed about this:
1- When i open the input field of the chatbox the movement stops completely. But of course, i can not send my own commands aswell, so that does not even work as a temporary fix.
2- The more manueverable a ship is, the more intense is its “dance”. I actually lose all the control for several seconds when i get my hands in a interceptor, while i almost do not notice the movement when playing a protection frigate.
I am not sure whether it is a bug or a problem with my computer/internet connection, but i’d love to know :stuck_out_tongue:

The ship overcompensates for movement in various directions, causing it to oscillate. I cannot tell if this is by design or a bug, but flying in expert mode prevents it. (Though it means you cannot easily aim off-centre.)

Seems like latency issue. Press f11 to show your ping. Server selection is currently in testing now, may be you were assigned to the wrong server across a world from you.

 

As for me, ping 30 is usual, but sometimes, it rises to 250… This is a beta, just report about wrong server selections with logs. Thanks for your patience and understanding.

The ship overcompensates for movement in various directions, causing it to oscillate. I cannot tell if this is by design or a bug, but flying in expert mode prevents it. (Though it means you cannot easily aim off-centre.)

It does make sense. How do i turn on expert mode?

It does make sense. How do i turn on expert mode?

Look at ESC menu. In game or controls section. I don’t remember.

Alright, i’ll give it a look once i log in again. Thanks :slight_smile:

Esc

Settings

Game

Dropdown box to Expert Mode

 

Fixed it for me, tell people if you see this on the forums we don’t want to lose players to this.  It was infuriating.