failed initiate renderers"

current D3D device is not supported by game

what to now?

i have integrated grapchic card intel g33 g31 intel chipset family

drivers for it are latest and for motherboard too. running windows vista ultimate any ideas?

Is your direct x up to date?

i have directx 11 for vista . degrade to 10 ?

I would try direct x9

error is identical. i tried 9.0c and 10 but no change - i try older vga drivers but no result.

my budget dont allow me buy pci card but want to play.

I think another user had the same problem with and he also had the same grafic device as you.

Hope we will find a solution for that issue.

my config of computer is dual core intel 2,33ghz 2gb memory kingston motherboard gigabyte , tried windows xp both sp2 and sp3 before and cant get it to work.

i tried use quad cpu and more memory and change motherboard to asus with “stronger” integrated grapchics , but looks like integrated grapchic cards are umm. bad thing is that other games work fine (like mmo browser games based on unity engine/flash engine etc)

Hope this will be fixed, but for now there isnt anything I could do.

ok thanks for help , would be good if issue get reported to programmers so they can make solution in future …

I think they already know about it since this issue already happened to another user.

will post here in next week if i can play or not. keep heads up! thanks anyway

Thanks for the report I will come back to you when I get some news.


There are only two recomendations that I can give in case if you encountered a “failed to initiate renders” issue:

  1. report on that on the Closed beta test forum (don’t forget to attach all necessary logs)

  2. reinstall newest versions of directX and videocard drivers

am having the same problems as the rest off the guys… downloaded the client but cant get onto the game

Can you message me what error you get?

It seems that in this case you need a new computer.

This configuration you have described, will run only games light-based browser notify.

I find it hard you can run the Star Conflict with your current equipment.

UpGrade is the solution!

other games work fine , like eve-online darkorbit etc. i see that this game just not support integrated grrapchic cards… cant affort new one at this moment , would like to test it but notthing i can do i got directx 10 , i try other versions with no hope, tried other grapchic drivers with no result .

I got the same trouble and i can play other games perfectly fine… even tryed re-installing the game just to be sure

Processor: AMD Athlon Processor 2650e 1.60 GHz

Ram: 3GB

Op System: Win 7

Manufacturer: eMachines

Graphics Card: ATI Radeon X1200 Series

Might look bad but it can run huge games that people said would never work on it… (from Dark Orbit to Skyrim)

I will help in any way i can…