Dysfunctional NY18 Offer

So far this quest has worked normally up until yesterday where the mission “Object NY18. Special offer” suddenly became greyed out and considered “completed” with 0/0 despite this mission only giving me 4 out of the 7 total modules that it should be giving out. Attached are screenshots from in game showing the error and total parts available to back up my claim, along with the game logs from the last run instance of the game.





have you been showing up every day?



22 hours ago, evo888 said:

have you been showing up every day?

That I have, yes. It is rather unusual since normally the progress up to the point of this bugreport should be “6 parts” out of the supposed 7 total (at least from what I gathered by asking), yet only 4 were given total before the offer broke. This was also accompanied by various other missions in Ellydium breaking down (“Kill the Crystalid Predator” mission asks to spawn in Ellydium Base/Leviathan despite being in the sector with no indicator of where the target is, and this also happens for any of the “Kill Crystalid [xyz]” missions. The Ellydium Transport quest only worked once, but future transport spawns failed to trigger the second objective indicator to complete it.)


I just got “Day 6” rewards despite having previously been given the “Day 4” rewards. Still missing a day’s worth of rewards all the same.