Dead keys difficult to use / keyboard language

When I use in-game text chat in Star conflic, it seems I have to hit the spacebar after hitting the apostrophe ( ’ ). In every other application I know it is only required to hit spacebar after hiting the apostrophe key in cases where it is followed by a vowel. When an apostrophe is follwed by a consonant, other applications would simply print the apostophe followed by the constant.
I belive the apostrophe in such case is called a “dead key” . I waits for the next character before it is printed to screen.

This deviating behavior, which makes it necessary to hit spacebar after each apostrophe, is extremly frustrating, since I am used to typing without having to use the spacebar after the apostrophe. Such is default behavior for any application. and from reading chat, I belive others suffer from the same issue as me.

An example of the problem to clarify the issue:

When I type: “I’m a fox” the result will be “I a fox”. Instead of printing the " 'm " it leaves it out all together. Imagine the frustration when I type " I’m sorry, I can’t help you with that problem."  and the chat reads “I can help you with that problem.”

I use Windows 7 64-bits.
My keyboardlangue / keyboardlayout is “Dutch - US (international)”.
I noticed that when I change my keyboard-layout in my operating systems settings to Dutch - US (without the international) the apostrophe is no longer a dead key and thus appears as soon as it is hit. However this no longer allows to type vowels with an apostrophe added to them, like the following characters: é ú í á .
I would prefer not having to change my keyboard layout to correct an issue wich I only have with Star conflict, and results in more issues outside this game.

Reproducing the issue:
I belive the issue can be reproduced in Windows 7 by setting the keyboard language to “Dutch - US (international)”.

Affected by this issue:
Affected by this issue is in-game chat. When typing text in any ingame chatbox, this issue occurs.

Tried to reproduce this to understand…

In my keyboard layout (german), dead keys are ^, ´ and ` (however not ’ )

same behaviour, albeit i am used to type a space after those


usually the op system doesn’t send a dead-key, until you hit spacebar (so thats windows) or another key


for me hitting a consonant after a dead key results in SC chat to not display any of those two characters however;

^m just won’t display either ^ or m for me; â works fine.


But basicly reproducible with other keyboard layouts as well with dead keys.

Alright, so that confirms other people have the same issue. Even tho it doesn’t bother everyone, it’s definetly there.


So now I wonder, can this be resolved? Is this a bug that might be patchable by the developer?