Crash when entering a game or during it

Hi DEV Team,


I am experiencing the same issues:

  1. During game play, either Map of any kind of missions, the game entirely freezes for 2-3 seconds (audio included), then it abruptly exits to the Operating System without any error.

   a) if in a battle, I can rejoin the battle (if not over yet);

   b) if it crashes within the same battle, I may or may not be able to rejoin. 

  1. If I jump to a location for a mission and the game crashes within the mission (or even prior loading the mission), I lose the 5 Iridium and I also lose whatever resources I managed to gather prior to the crash.

  2. After a crash, when I log back in, free flight in Map is exhibiting terrible performance, the frame rate is like 5-7 per second, I can barely move.

  3. Abnormal performance and crashes also occur after purchases.

  4. Not related to the current reported issue, but I have to mention it (and this is old!), the skin/texture issue in Hangar mode: black pixels show on weapons, and for Hydra and other skin-like ships, it is entirely covered with big black pixels like it is being censored.


I also need to mention that the ’ Out of system memory’ must be a code issue, since it is very unlikely to actually happen on an 8GB RAM platform with swap-1 size: 41.17 GiB used: 132.8 MiB (0.3%). This is a Gaming laptop, so please allow me to exclude it out of the reason list for the bad performance and crashes. 


Latest game.log file shows Warnings, Errors and the below Fatal Error:


23:22:14.012    FATAL| ===!!! Out of system memory !!!===
23:22:14.012    FATAL| Unsuccessfully tried (364 times) to allocate 4096 kb from Top
23:22:14.012    FATAL| System allocator borders 0x0x386aa000-0x0x38a00000


I’ve been playing the game for quite a few years now and I have experienced these issues before, then there were some updates that apparently fixed them, at least for a while. Now these issues seem to have regressed. 


Please find attached the latest logs.


Thank you.

[2022.01.07](< base_url >/applications/core/interface/file/attachment.php?id=21586&key=e192552ec04215d10d811afc6e0bfe08)

Accepted as SC-115968

Hi Admins,


Please note that today I got pushed out of the game to the OS (Linux Mint) while in a skirmish battle. Logged back in into the battle, won it, and I got pushed out again while Loot Search, this is the first time it happens, without any error or message whatsoever. 

I also noticed the ‘Exceptions’ folders, there are 2 folders named ‘exceptions’ and ‘Exceptions’, do you want me to provide you with the log files from those folders too?


Please find attached the logs from the ’ logs’ folder.


Please let me know if you need the exceptions too.


Thank you.


Kind Regards,

[](< base_url >/applications/core/interface/file/attachment.php?id=21598&key=c374e94e786bfc838301c48103609ba9)

Hi @Skula1975,


Sorry for bothering you, got kicked out twice today, but the second time I got kicked out while selecting a ship (Waz’got). 

The error shown in the game.log file is:


22:49:15.797    ERROR| Wrong vertex format (may model file out of date?) in mesh 6 of model file models/ships/race_2/h/r2_h_t1


Logged back in, the ship is selected.


Thank you.


Kind Regards,


I solved this problem for my configuration :


I’m using client update from 22.2.2022

After only updating to the new client  I still experienced crashes as @Gallaxy30798 has descriped

Then I started Steam, went to Library, right clicked on Star Conflict => Compatibility and set “Force the use of a specific Steam Play …” and had chosen Proton Experimental

 After this the game was automatically uninstalled and a new client installed after that. (With this you loose all stored Presets of your ships)


Now I can play without any crashes all missions, Openspace etc. so far.


Some thoughts/guesses why it works now :


It could be that actually the uninstall/new install procedure solved the problem (Perhaps together with the new game client)

The bug could be, that SC doesn’t choose the right compatibility tool by default.

It also might work with other versions of the Steam compatibility tool, but I won’t check this, never change  a running system. ![:)](<fileStore.core_Emoticons>/emoticons/001j.png “:)”)