Contracts problem

Hello everybody!

I am experiencing an issue - I’ve signed 2 contracts:

  1. “Out of nowhere” - I need to kill/assist 3 fighters with the disintegrator

  2. I don’t remember the name - I need to repair my allies with the Directed repair module for 20000 pts.


I am using Acid Hydra with the directed repair module to do both mentioned above contracts, but after several kills ( fighters, sometimes I even checked what type of fighters I was shooting at ) and at least some repairing done, I still have 0/3 and 0/20000.


Can anyone tell me what am I doing wrong? Or is it a bug?






The problem affects those two contracts so far - I’ve turn them down, completed some from the lower loyalty levels, signed them again, and still nothing. I tried Acid Hydra, as well as Hydra 2, with no luck. Am I the only one with this problem?

Ok, I’ve got my problem solved. I had T1 interceptor in the inter slot - after swiching to T2 I was able to complete contracts rank 7+. Turned out, that “you need T2 ship or higher” applies to every slot, not only the ship that was being used.

a double click on any said contracts

will open a second little window where

the requierments are stated for each mission

RTFM :wink:

I’ve read it. But hey, it’s not clear that “you need T2 ship or higher” means I have to use T2 ships in every slot.