Can't start game in lubuntu


I am new to linux, and was having trouble starting star conflict. I downloaded steam through the apt-get install steam, and then installed star conflict from inside steam. However, when I try to launch star conflict, it brings up a window for about 0.5 seconds and then closes it. Any ideas?

Did you install your graphics drivers?

Um, not if it didn’t install them when I ran the boot disc

How would I go about this? Sorry, I am completely new to linux.

I have intel integrated graphics.

Just tried downloading the intel installer from their site for ubuntu. Installed the drivers, and still nothing on star conflict.

use the edit button

I don’t think lubuntu is supported.

I’m willing to wager a lot of required libraries are missing. Mostly does lubuntu come with opengl support?


A quick check shows that the game supports unbuntu 12.04 LTS.


I always use ther Server install. Though I only use Unbutu for servers though…


When you get to the stage where it is asking your for packages, I would recommend selecting all of the library options. I won’t hurt anything unless you have limited storage space. Double check to verify you marked everything for OpenGL.


Though the best option for you is to use windows.


If you don’t know anything about installing a linux, don’t try. It may burn you.

edit: note for others, this instruction is incomplete, please read rest of thread.

you don’t need to install graphics drivers for intel cards. those are already open source and included with the linux kernel.


it does also not matter which ubuntu base you take, all packages should be available somehow, so you can even install another kernel with another ubuntu.


  1. try to start star conflict manually from a command shell. what does it write?

    cd “~/.steam/steam/SteamApps/common/star conflict” && ./StarConflict

(&& is just there because i wrote two commands in one line, you can enter them separately after each other and press enter)


  1. maybe you miss libraries. maybe your system misses opengl stuff (as mentioned). maybe your card doesnt do 3d. hard to say.

type “ldd StarConflict” in the same folder, to get a list of all the libraries the app uses. is anyone there missing (libcurl and libudev are allowed to miss)

thats LDD written with small letters. you can use it on any executable, it will tell you the libraries it uses.


  1. check “glxinfo” command output, do you have 3d acceleration? (needs the mesa-utils package)

search the output of this tool for “direct rendering: Yes” or “No”, quicker way:

glxinfo | grep "direct rendering"

btw. you can also use the tool “glxgears” from the same package, which displays some rotating gears, and writes the frames per second into the terminal, to see, if graphics are accelerated. wait a bit, watch them turn, escape, look if it wrote something nice above 50 :slight_smile:


  1. another try is not installing steam system wide via apt-get, instead, remove it, and install it via download from the steam page

it will install per default into ~/.local/share/Steam for your user only.

should the problem be steam. but does not sound like it. so don’t do this if it sounds complicated, since i hardly imagine that’s the fault. have you tried other steam apps?


  1. you can put ldd output and glxinfo output here, in spoiler&code tags.

[spoiler] [code] paste output [/ code] [/ spoiler] without spaces in the []-tags.

looks like this


  1. ask if anything i wrote is unclear.

  2. don’t panic.

Sorry about not responding for so long, I have been trying to triboot my new ssd, and have had tons of problems getting windows 7 and lubuntu on the with grub2 bootmanager as mrb. However that much is now working.


In response to DavidGill,  I have ran ubuntu before, but has been awhile, and I am very stubborn I do not want to simply give up and go to ubuntu 12.04 because I can not figure something out.


In response to g4borg,

  1. I tried starting it manually, but it said directory not found. In fact the only folder under my steam folder is logs.

  2. I know my card supports it because I have been playing it in windows 7, but just moved over to an ssd so had to reinstall windows, and am dual booting lubuntu. says direct rendering yes, and when I ran glxgears I am getting on average 59.75 fps

  1. I have not tried other steam apps, and I don’t believe that is the problem. When I try to open star conflict it pulls up a blank window for about 0.5 seconds and closes. So I know that steam is linked to it, but rather it seems I am missing something.

5.I would if I knew where the actual steam folder was located. It seemed to install fine, but inside of my documents it only contains the folder logs.

Thanks for the support everyone. I would like to get this figured out and help anyone else with this problem.

Update! I found the directory, I forgot the . before steam o.0. I tried launching star conflict from terminal then, and here is what I got

./StarConflict: error while loading shared libraries: cannot open shared object file: No such file or directory

So I searched libcrypto in synaptic package manager and downloaded all of the uninstalled packages listed. I then tried to start Star conflict, and it did the same thing =L. It also gave me the same error. I did a little research and found something about openssl 1.0.1, but I have openssl 1.0.1. Any suggestions would be great



Update 2 I used this command

$ ldd /path/to/my/app | grep -i "not found"


to get this output => not found => not found => not found => not found => not found

SDL might be the main trouble here, which is an opengl wrapper many 3d apps use.


i searched for the package it is contained in in my own buntu box, however i might have a different version


# sudo apt-get install apt-file
# apt-file update
# apt-file search libsdl2-2.0-0
libsdl2-2.0-0: /usr/lib/x86_64-linux-gnu/
libsdl2-2.0-0: /usr/lib/x86_64-linux-gnu/

which means, libsdl2-2.0-0 is the package you have to install

if the package is different, find out by apt-get search libsdl2

the other packages:

  • xrandr might not be needed, and is the library for multiple monitor setups. the library name is libxrandr2

  • curl might not be needed, it’s a network string library, and is located in libcurl3

  • crypto might not be needed. you can search with apt-file for it.

  • udev might not be needed, and even disturb your system setup, so only install if every other possibility is exhausted.

i say, try install SDL, and then look if it works, report back then.

Ok i installed it, but still nothing. I looked at libxrandr2, and I already have it. Same with libcurl3.


I also ran the commands again to check the errors and the errors are the same.


I have located the crypto file, but not the udev file.


The package manager says I have udev.

do you have that SDL file on your filesystem now?

as i said, crypto and stuff is not important. SDL however is.

does your executable still miss it?

Here is where the apt-file search found for libsdl2-2.0.0

libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/BUGS.txt
libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/CREDITS.txt
libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/README-SDL.txt
libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/README.txt
libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/changelog.Debian.gz
libsdl2-2.0-0: /usr/share/doc/libsdl2-2.0-0/copyright


that pretty much means you only have the documentation installed. you might need to run a apt-file update first.

i mean, ldd StarConflict, what does it say?

When I just ldd this is output =>  (0xf776b000) => /home/djfrost/.steam/steam/SteamApps/common/star conflict/./ (0xf76db000) => /home/djfrost/.steam/steam/SteamApps/common/star conflict/./ (0xf7555000) => not found => not found => not found => not found => /home/djfrost/.steam/steam/SteamApps/common/star conflict/./ (0xf752a000) => not found => /usr/lib/i386-linux-gnu/ (0xf73f5000) => /usr/lib/i386-linux-gnu/mesa/ (0xf7395000) => /lib/i386-linux-gnu/ (0xf7390000) => /usr/lib/i386-linux-gnu/ (0xf72a7000) => /lib/i386-linux-gnu/ (0xf7260000) => /lib/i386-linux-gnu/ (0xf7243000) => /lib/i386-linux-gnu/ (0xf7227000) => /lib/i386-linux-gnu/ (0xf7078000)
    /lib/ (0xf776c000) => /usr/lib/i386-linux-gnu/ (0xf7056000) => /usr/lib/i386-linux-gnu/ (0xf703d000) => /usr/lib/i386-linux-gnu/ (0xf702a000) => /usr/lib/i386-linux-gnu/ (0xf7026000) => /usr/lib/i386-linux-gnu/ (0xf7020000) => /usr/lib/i386-linux-gnu/ (0xf701d000) => /usr/lib/i386-linux-gnu/ (0xf7004000) => /usr/lib/i386-linux-gnu/ (0xf6ffe000) => /usr/lib/i386-linux-gnu/ (0xf6ffa000) => /usr/lib/i386-linux-gnu/ (0xf6ff6000) => /usr/lib/i386-linux-gnu/ (0xf6fef000) => /usr/lib/i386-linux-gnu/ (0xf6feb000) => /usr/lib/i386-linux-gnu/ (0xf6fe5000) => /usr/lib/i386-linux-gnu/ (0xf6fd8000) => /usr/lib/i386-linux-gnu/ (0xf6fd4000) => /usr/lib/i386-linux-gnu/ (0xf6fcd000)

When I ldd with " not found"  I get => not found => not found => not found => not found => not found

I did run an apt-file update, and sudo apt-get update

I tried sudo apt-get install li bsdl2-2.0-0, but it says I already have it.

i just saw, that steam actually ships with this libSDL library. so i am curious if steam installation is correct there.

at least locate libSDL brought me some .so files in the steam library.

do you have any other steam apps that you can try?

do you also have libSDL2 files in some .local/share/Steam/… folder?

otherwise i am pretty much at the end of my knowledge.

will later try to update my sc and try if it works for my intel card still.