cant start game (ArchLinux)

Hi, when I try to start the game in steam I get the following error… 

Game update: AppID 212070 "Star Conflict", ProcID 16489, IP 0.0.0.0:0
ERROR: ld.so: object '/home/user/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/user/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
Setting breakpad minidump AppID = 212070
Steam_SetMinidumpSteamID: Caching Steam ID: 1234567891234567 [API loaded no]
libGL error: MESA-LOADER: could not create udev device for fd 747
unknown chip id 0x6898, can't guess.
libGL error: failed to create dri screen
libGL error: failed to load driver: radeon
X Error of failed request: GLXBadFBConfig
  Major opcode of failed request: 156 (GLX)
  Minor opcode of failed request: 34 ()
  Serial number of failed request: 81
  Current serial number in output stream: 79

I’m on ArchLinux (64bit + all available lib32-pkgs) 

Kernel : Linux 3.14.2-1-ARCH (x86_64)

Desktop Environment : XFCE 4

CPU: AMD Phenom II X4 955 (BE)

GPU: Radeon HD 5870

RAM: 8GB

-VGA Drivers (open source)-

xf86-video-ati 1:7.3.0-1

mesa 10.1.2-1

ati-dri 10.1.2-1

 

edit1: If I run the game directly from ~/.local/share/Steam/SteamApps/common/star conflict/StarConflict

I first needed to link libudev ($ ln -s /usr/lib32/libudev.so libudev.so.0) but then I get the error:

./StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./StarConflict)
./StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by ./StarConflict)

which seems to be the same bug posted here: [http://forum.star-conflict.com/index.php?/topic/22923-game-requires-outdated-version-of-libcurlopenssl/](< base_url >/index.php?/topic/22923-game-requires-outdated-version-of-libcurlopenssl/)

 

edit2: okay strange, the game starts now when launched in steam … I think the solution was to do the symbolic link in ~/.local/share/Steam/SteamApps/common/star conflict/

I can confirm that I have the same problem on 64 bit Debian. I can also confirm that symlinking libudev does solve the problem. Though in my case it was:

 

ln -s /lib/i386-linux-gnu/libudev.so.1.4.0 libudev.so.0

I am using 64bit debian with no issues and alpha catalyst driver 14.6 Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux

I upgraded a few minor packages to jessie(completely avoiding core xorg libraries) as that resulted in xorg not rendering.

I have a problem starting the game on Ubuntu but on mine it’ll start go to the EULA but it won’t display any buttons so i can’t get past it