Can't Launch SC, tried a few things

Ive had a break from playing for a few weeks.


I originally installed it straight from the Gaijin website and it all worked amazingly on this computer, I used to play every day and got to something like Pilot rank 12 where I could have a 4th ship in my combat slot.


A few days ago I tried to fire up the game and did so the usual way I used to  (desktop icon taking me straight to the Gaijin launcher for SC)


The launcher needed around about 2GB of updates to play again (understandably, as its been a few weeks)


Let it do it’s thing, hit PLAY, got this error message:

(first pic showing Star Conflict launcher and error message):


Tried to repair using the launcher, got a very similar message (“cant repair game”).


Deleted it (applications/remove programs) and redownloaded the launcher from Gaijin. it didn’t install the game, just the launcher this time took like 2 seconds and I still get this exact same message when trying to play the game.


Got fed up…deleted it all again and gave up


Next day, decided to try and install it through Steam. Actually seemed to install this time (took forever) but it wont even launch the Launcher now…I am now getting this error message:

( Second pic showing a Steam error )


Now at this point I am getting fed up and the hassle of trying to run this game is outweighing the enjoyment I actually get from playing it, but I am not giving up as I have sunk a LOT of time into it


But I continue to try… the Steam error has a little link that takes you to a troubleshooting page, I can confirm that I have done EVERY thing on that page, from deleting the Steam download cache, to verifying game files, and even reinstalling the game to a different hard drive.


This shouldn’t be necessary as it used to work smoothly on this PC, I used to play on the highest graphical settings with no problems at all.


All I can think of is I vaguely remember updating my Nvidia drivers not so long ago for a game I was trying to play, I cant even remember what it was or anything, but everything else works fine on this PC (I play Destiny 2, Warframe, and a few others daily).


I reached out to the Facebook ‘official’ Star Conflict page and got no help other than being redirected here so here I am.


Anyway sorry for the lengthy post I hope I covered everything here and let me know if you have any suggestions 




It may be worth noting that there seems to be no problem with my account as I can log into the main website OK with it still so I don’t think it is an issue with my account (inactivity or something)


On the main launcher, if you look at the pic, the “Register” menu tab is highlighted…


I tried hitting register and it just took me to the website where I was unable to log in because it seems to be aimed at new players only who want to download the game for the first time…all I could do here was create a new account which I deffo don’t want to do. If I have to do this or my account has been deleted, I will not continue playing. I don’t want to lose my progress and ships and am not redoing all of that hard work

Try to disable the antivirus before starting the game, if it doesnt work try the same thing again but this time run with admin rights, maybe it will help.

I disabled my antivirus and also allowed the game to bypass Windows Defender (I should note that the game ran before without all of this)


As for running as admin…not possible I am afraid. The game doesn’t even seem to be installed it is just the launcher window, it looked like it was reinstalling but theres no files. and in the game folder, the SC application file is just a browser link which cant be run as admin. I cant run anything as admin it just doesn’t have this option when I right click (even the Desktop icon) no matter what I try, I can’t get it to install or run properly


Now I am having problems with the SC Website regarding my account too.


So I go to the website and try to log in. My details are all saved on the site, so when I attempt to log in there are 2 accounts stored there (mine and my gf’s), so I choose mine, hit Authenticate, it logs in…for about 1 second, then logs straight back out of my acc on the the webpage.


Have I been deleted for inactivity or something?  I mean I should still be able to run the launcher and log in to another account if I have. I was a paying customer, bought ships and GS etc. I had a few months off because our Son died and I return to find that: 1. I cant load up this game anymore and 2. It is looking like they have deleted me altogether.


If this is the case it is disgusting. I feel like I am not going to solve this problem so I pretty much am ready to give up…and my money has been wasted.


It has been 3 days now, on and off trying everything, I still am getting the same errors in the pics from my OP. I have removed the steam version altogether now, apparently access was denied to my own fricking game. I hadn’t changed anything, I just didn’t play for a few months. Now I cant play at all and I am really annoyed that I spend money on a f2p game that I didn’t need to (I supported the devs) and just get treated like this with no real answers or help.




Try using the guidelines provided to put a proper bug report and lets wait for the support to see whats wrong.