keijinakam711488

Slow load time/ open space crashes

Recommended Posts

Got a couple issues here that I think are semi related. First my game takes a very long time to load. Now when starting from steam I also get the LD_PRELOAD errors and libcurl issue which I can fix with loading the game from a separate console from a shell script while steam is loaded which echo's the app id.txt and then calls this command string:

 

LD_LIBRARY_PATH=/home/<username>/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/:/home/<username>/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ ./StarConflict

 

I then had no issues with the LD errors or curl, but then SDL was missing so I compiled a copy of 32 bit libsdl2 on my 32 chroot and installed it as a multilib compat32 package, now the game starts with no errors what so ever but yet still takes 5+mins to load.

 

Also during in game I can PVP, but if i do the anthill daily pvp I will crash within a few seconds of entry, else all other pvp works great and even pve missions. But when I go out into deep space a zone Dreamland crashes for sure and several other zones will crash at random. I am not that far in levels so I have only wandered around some of the beginner areas to explore.

 

I also tried various steam compatibility modes to test the windows version of the game using Proton of various versions up to 4.10 when using the windows version of the game it crashes in open space as well but it locks up where as on linux it just disappears to desktop.

 

Let me know which specific situations you want me to get a log file for. I cleared my logs of other times since I dont remember which sessions they were from. I will try playing open space now and save my .logs and do my pvp dailies, when I crash I will write down in a notepad which log file folder it was so I remember and can upload it to here.

 

I suppose it would also help to post my system information:

Slackware Linux x64 14.2 w multilib, Kernel 4.9.19, Nvidia Driver 410.73, GCC compiler 5.5.0, KDE 4.11

Amd 8350/32GB/GTX990TI

 

EDIT #1

Ok so I now have a game .log file set and just crashed in the shipyard after killing pirate baron. It seems it is actually memory allocation.

14:52:00.300    FATAL| ===!!! Out of system memory !!!===
14:52:00.300    FATAL| Unsuccessfully tried (549 times) to allocate 4096 kb from Top
14:52:00.300    FATAL| System allocator borders 0x0x42fd0000-0x0x43300000
14:52:00.300  WARNING| ======================= MEMORY USAGE ============================

 

I will reload the game and try to watch memory monitor as it crashes. Should be enough memory a 32 bit program gets 4GB of address space.

 

Edit #2

Seems I was only using 1.3GB at my last crash but the log did not show any fatal errors in game.log. I will just keep playing tonight and see weather I can figure something out.

Share this post


Link to post
Share on other sites
On 2/9/2020 at 1:03 AM, keijinakam711488 said:

I now have a game .log

Please, zip and attach all log files

Share this post


Link to post
Share on other sites
9 hours ago, keijinakam711488 said:

Here is the log file for the time when it reported running out of memory

 

Ther aren't rows with out of memory message in this logs, like that:

On 2/9/2020 at 1:03 AM, keijinakam711488 said:

14:52:00.300    FATAL| ===!!! Out of system memory !!!===
14:52:00.300    FATAL| Unsuccessfully tried (549 times) to allocate 4096 kb from Top
14:52:00.300    FATAL| System allocator borders 0x0x42fd0000-0x0x43300000
14:52:00.300  WARNING| ======================= MEMORY USAGE ============================

Is it right logs?

Share this post


Link to post
Share on other sites

Please, try to find Exception folder near the logs folder. If will found, please, zip and attach it

Share this post


Link to post
Share on other sites

Allrightey here is the exceptions i put both folders one with the dumps and one with other logs.

exceptions.zip

Edit1:

I should not have probably put so much stuff with that zip file.

 

I was doing a quest today got through a couple open space quests and had another out of memory dump. I will post the Exception here  2020.02.12 18.26.38.zip. Hope that helps.

2020.02.12 18.26.38.zip

Share this post


Link to post
Share on other sites

I might have figured something out. I do not know why this did not seem to be showing up before but despite all libraries loading at start and no errors when the game crashed I saw a libcrypto.so.10 error illegal instruction. So I checked the steam ubuntu32 folders for that specific one and it was not there, so since im on slackware it has 1.0.0 installed and made a link from /usr/lib to there of libcrypto.so.1. Still has the 5 minute load time but I have made it through a few sectors of space without a crash. I will report on that later.

 

Nope still randomly crashes but some zones seemed to last quite a while like the Felony areas managed to mine some ore. I also got a unknown Illegal Instruction no more ones for libcrypto popping up.

 

 

Share this post


Link to post
Share on other sites
On 2/8/2020 at 9:03 PM, keijinakam711488 said:

Slackware Linux x64 14.2 w multilib, Kernel 4.9.19, Nvidia Driver 410.73, GCC compiler 5.5.0, KDE 4.11

Have you ever considered updating? 4.9.19 is like 3y old and the 4.9 series is already at 4.9.213, nearly 200 releases... and used Nvidia Driver is also like 1.5y old.

Share this post


Link to post
Share on other sites

Regarding the crash with star conflict it seems linking that file did not help it still crashes intermittently and only in open space or custom pvp mode of the day and some zones are worse than others. For instance Dreamland always crashes within 1 minute of entry or less. Felony star system ones seemed to be able to fly around quite a while harvesting and killing aliens. Also the transit route one seems to stay going quite a while. I will play tonight and test out a few more areas. And regarding the upgrades I will look into getting up to date should that be the issue.

 

Mainly to be sure I have no issues with software on my pc. I installed my pc about 2 years ago and chose 4.9.19LTS to make it easy to get vmware modules compiled, as well as nvidia kernel modules. My laptop actually has slightly newer stuff on it its on slackware-current 15.0, once the full release comes out I will fully update my desktop rig. Now the laptop though will be unfortunately stuck on 5.0 since the legacy nvidia driver for its Quadro FX2800M would not build no matter what patches i put on it with anything newer literally took me a day of compiling every major version moving backwards through the releases back to 5.0 just to get it working. If that laptop ever needs a new version past that it will get retired. But its still a pretty nice laptop yet IBM W700 17" with a i7 quad core and 24GB ram and 3 hard disk slots n a blue ray burner and a wifi N card modded into it.  Sorry I drifted off topic too much here, I should move to another thread area if I am gonna talk about stuff like this :P

 

 

Share this post


Link to post
Share on other sites

Found a fix for me to get to play, it seems steam released proton 5 switching to compatibility mode with that prevents game crashes and I was able to go quite a few places and do the special anthill battle for the day.

Edit:

Proton works without crashing but its fps sucks on pvp, so I will continue trying to get the linux version up somehow and find out where the problem lie.

Share this post


Link to post
Share on other sites

This is now fixed you can close my thread. I have updated nvidia driver 435.21 and my crashes seem fixed so its not a libc issue. I am playing on linux slackware fine just now.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.