rAZ0r

Constant stuttering and short freezes when flying

Recommended Posts

Description of the problem, what happened.

When flying in ship in open space or missions or wherever, the screens freezes every few seconds for like half a second or so.

My Ping is 50-60 and FPS is constant 30... have tried changing gfx quality from low to high... it doesn't change a thing.

Each time a stutter happens a warning like these is added to game.log:

21:15:20.877  WARNING| frame 17122 gameGlobals.frameTimeReal is too large (0.873087)
21:15:25.884  WARNING| frame 17263 gameGlobals.frameTimeReal is too large (0.650512)
21:15:47.929  WARNING| frame 17943 gameGlobals.frameTimeReal is too large (0.967555)
21:15:58.236  WARNING| frame 18247 gameGlobals.frameTimeReal is too large (0.843060)
21:16:30.138  WARNING| frame 19259 gameGlobals.frameTimeReal is too large (0.530567)
21:16:41.435  WARNING| frame 19604 gameGlobals.frameTimeReal is too large (0.663089)
21:17:19.761  WARNING| frame 20818 gameGlobals.frameTimeReal is too large (0.750376)
21:18:09.258  WARNING| frame 22405 gameGlobals.frameTimeReal is too large (0.275004)

 

I have attached all the logs, can someone please explain to me if this is video related or network related, or is it unrelated to those?

Can I try doing something on my machine to work around it?

 

I'm running:

Arch Linux 5.2.14-arch2-1-ARCH #1 SMP PREEMPT

CPU Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz

GFX NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2) - (binary driver nvidia 435.21-4)

RAM 16GB

chat.log combat.log game.log game.net.log

Share this post


Link to post
Share on other sites

Server-side lag. Not an issue with your game.

Share this post


Link to post
Share on other sites
6 minutes ago, rAZ0r said:

I'm not talking about occasional rubber-banding they are like half/quarter second freezes.

Are you 100% sure it's server side?

Yes.

  • Thanks 1

Share this post


Link to post
Share on other sites
18 minutes ago, rAZ0r said:

yes.. it's happening constantly...

it's so annoying/hard to fly/fight when screen freezes for half second every 3 seconds

I was about to ask for Dxdiag but I see you listed your specs above.

Linux users often experience weird problems for seemingly no reason. I didn't even think to look at what OS you had.

The best you can do is

1: Use a better operating system.

2: keep posting logs and maybe a recording of the issue so that maybe the devs can eventually fix it.

Share this post


Link to post
Share on other sites
1 hour ago, rAZ0r said:

yes.. it's happening constantly...

it's so annoying/hard to fly/fight when screen freezes for half second every 3 seconds

Do you play on a ssd or HDD? It looks to me that these stutterings all hapened after a player joined, and SC locks while loading new assets.

Share this post


Link to post
Share on other sites
1 hour ago, TheDarkRedFox said:

I was about to ask for Dxdiag but I see you listed your specs above.

Linux users often experience weird problems for seemingly no reason. I didn't even think to look at what OS you had.

The best you can do is

1: Use a better operating system.

2: keep posting logs and maybe a recording of the issue so that maybe the devs can eventually fix it.

lol, take a look at this section, a majority of the reports are not caused by the OS itself, but by the fact that the devs claim that Linux (or Mac) is a supported target, while leaving it unsupported with a game client in a bad state.

Share this post


Link to post
Share on other sites
2 hours ago, John161 said:

Do you play on a ssd or HDD? It looks to me that these stutterings all hapened after a player joined, and SC locks while loading new assets.

i have 3 HDDs in RAID that read at 400MB/s and have ~8 GB of free RAM when game is running, so all the resources are cached in RAM and there is no disk activity at all during gameplay.

I will try moving the game to SSD RAID and try there, but don't think disk is the issue.

 

4 hours ago, TheDarkRedFox said:

I was about to ask for Dxdiag but I see you listed your specs above.

Linux users often experience weird problems for seemingly no reason. I didn't even think to look at what OS you had.

The best you can do is

1: Use a better operating system.

2: keep posting logs and maybe a recording of the issue so that maybe the devs can eventually fix it.

1. a better operating system?

2. what other logs do you need me to provide?

I'm looking at the logs while the game is running and as I have already said "WARNING: gameGlobals.frameTimeReal is too large" gets logged each and every time the freeze occurs.

Can some developer or someone with more knowledge explain what that warning means?

Will try to capture the video and upload it somewhere.

 

BTW have changed video settings in game.. I have steady 60+FPS on medium quality and 50-70ms PING so am pretty sure it's not a hardware issue.

Share this post


Link to post
Share on other sites

Here is the video showing the stutter and log https://www.dropbox.com/s/rl8k2pc0fq5zf9g/star-conflict.mkv?dl=0

Also would appreciate if some developer could look into this.

Responses like it's "100% server side problem" that then changes into trolling "use a better operating system" are not helpful and are just wasting everyone's time.

Linux is stated as supported operating system and my spec exceed both minimum and recommended specs stated on steam page.

 

Share this post


Link to post
Share on other sites

I see what you mean now.

This is definitely a problem on the client side not the server.

There just happened to be a MAJOR server connectivity problem at the time that you posted this, and I just assumed that you were talking about that. (it affected everyone)

 

I have no clue what could be causing this besides Linux compatability issues because you do have way higher specs in your system than are needed to run the game.

Share this post


Link to post
Share on other sites
7 hours ago, rAZ0r said:

Here is the video showing the stutter and log https://www.dropbox.com/s/rl8k2pc0fq5zf9g/star-conflict.mkv?dl=0

Also would appreciate if some developer could look into this.

Responses like it's "100% server side problem" that then changes into trolling "use a better operating system" are not helpful and are just wasting everyone's time.

Linux is stated as supported operating system and my spec exceed both minimum and recommended specs stated on steam page.

I will try to come back to you on Monday. Also the Linux support is a joke, and the minimum/recommended specs for linux are wrong, the recommended CPU would not even be enough for close to 30fps in Sec Con.

You could check CPU/GPU Utilization, VRAM Usage, but it shouldn't make any issues, your CPU is around the same as mine for this game, and GPU should be underused in my experience so not the cause (even your 750 ti).

Also pls check if the game also stutters like this with vsync disabled. (but I highly doubt that this is the cause)

Share this post


Link to post
Share on other sites

Have tried disabling vsync everywhere so now fps goes upto 80.. but it still stutters every once in awhile..

CPU usage is 20-30% on each of 4 cores and GPU doesn't warm up over 60deg C (it stays in green or barely enters yellow) on other games it warms up much more... am not sure how to see exact utilization of GPU.

Have tried running windows version through wine and i get over 100 FPS that way (and no gfx texture glitches) but stutters are still there.

Have also found some more info on other gaming forums. It seems it might be casued by crappy nvidia binary driver.

Looks like it's not star conflict client problem after all. Will post a solution/workaround here if I manage to figure it out.

Share this post


Link to post
Share on other sites
22 hours ago, rAZ0r said:

Have tried disabling vsync everywhere so now fps goes upto 80.. but it still stutters every once in awhile..

CPU usage is 20-30% on each of 4 cores and GPU doesn't warm up over 60deg C (it stays in green or barely enters yellow) on other games it warms up much more... am not sure how to see exact utilization of GPU.

Have tried running windows version through wine and i get over 100 FPS that way (and no gfx texture glitches) but stutters are still there.

Have also found some more info on other gaming forums. It seems it might be casued by crappy nvidia binary driver.

Looks like it's not star conflict client problem after all. Will post a solution/workaround here if I manage to figure it out.

UPDATE: it's not the nvidia driver issue after all, have tried running it on intel gfx and it stutters a lot too. Other games run great especially after tweaking nvidia configuration.

BTW server side rubber banding is back again.

Share this post


Link to post
Share on other sites

If there are a network problems, please, make separate bugreports with logs, screenshots and traces

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.