Sign in to follow this  
pd27

Dont run with amdgpu-pro

Recommended Posts

Error report
Describe problem and what you saw I buy new video-card: RX570 run SC and it doest run. Only write - cant find drivers.
Yes radeonsi no loaded? because loaded amdgpu-pro
What you expected to see SC
Conditions in which error reproduce nothin
Problem details Doesnt run with amdgpu-pro driver
Frequency of reproduction always
Time of bug  

 

./StarConflict
./StarConflict: /usr/lib/libcurl.so.4: no version information available (required by ./StarConflict)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  240
  Current serial number in output stream:  239

Share this post


Link to post
Share on other sites
1. After installation amdgpu-pro driver - SC dont run.
2. SC run.
5. always
6. ./StarConflict
./StarConflict: /usr/lib/libcurl.so.4: no version information available (required by ./StarConflict)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  240
  Current serial number in output stream:  239
7. yesterday, today.
8. Linux HomeSuse.asus.com 4.14.74-1-default #1 SMP PREEMPT Fri Jan 26 08:52:08 UTC 2018 (12e5c10) x86_64 x86_64 x86_64 GNU/Linux
MB: Asus sabertooth 990FX rev2. AMD FX6500 processor, videocard: Sapphire Radeon RX 570, OS: opensuse Leap 15

 

Share this post


Link to post
Share on other sites

System:    Kernel: 4.12.14-lp150.12.45-default x86_64 bits: 64
           Desktop: KDE Plasma 5.12.6 Distro: openSUSE Leap 15.0
Machine:   Device: desktop Mobo: ASUSTeK model: SABERTOOTH 990FX v: Rev 1.xx serial: N/A
           BIOS: American Megatrends v: 0901 date: 11/24/2011
CPU:       Hexa core AMD FX-6200 Six-Core (-MCP-) cache: 12288 KB
           clock speeds: max: 3812 MHz 1: 3812 MHz 2: 3812 MHz 3: 3812 MHz 4: 3812 MHz 5: 3812 MHz 6: 3812 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580]
           Display Server: x11 (X.Org 1.19.6 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1920x1080@60.00hz, 1680x1050@59.88hz
           OpenGL: renderer: Radeon RX 570 Series version: 4.5.13542 18.50.1.418
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 580] driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.12.14-lp150.12.45-default
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>

Share this post


Link to post
Share on other sites

May be it happen because amdgpu-pro have not x86 .so, and SC only in x86 version? In 2019 year...

Share this post


Link to post
Share on other sites
2 hours ago, pd27 said:

May be it happen because amdgpu-pro have not x86 .so, and SC only in x86 version? In 2019 year...

Why don't you install the 32 libraries of amdgpu-pro? Your bug report is more or less unrelated to Star Conflict and more that your system is not configured to run 32bit OpenGL Applications.

Share this post


Link to post
Share on other sites
12 hours ago, John161 said:

Why don't you install the 32 libraries of amdgpu-pro? Your bug report is more or less unrelated to Star Conflict and more that your system is not configured to run 32bit OpenGL Applications.

Because no x32 libraries in last amdgpu-pro drivers... And no since v17.40.
How to install it?

Share this post


Link to post
Share on other sites

Installation archive contained x64 and noarch packages.
More old versions dont know about current kernel and how to use it.

Share this post


Link to post
Share on other sites
7 hours ago, pd27 said:

Installation archive contained x64 and noarch packages.
More old versions dont know about current kernel and how to use it.

I did take a look at it, it seems like AMDGPU Pro doesn't support 32bit on Open Suse Leap, only on Cent OS 6 and Ubuntu 18.04. So you can either copy the libs form these archives on your system and hope that it may work and not break everything or use Mesa instead. Why do you even try to use AMDGPU Pro, there is at least for gaming no need for it. Also the third way would be to use a Distro that has 32bit support by AMDGPU Pro (namely Ubuntu :D)

Share this post


Link to post
Share on other sites
On 1/24/2019 at 6:10 PM, pd27 said:

I send log

I don't see a log files

Share this post


Link to post
Share on other sites
Quote

./StarConflict
./StarConflict: /usr/lib/libcurl.so.4: no version information available (required by ./StarConflict)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  240
  Current serial number in output stream:  239

All log...

Share this post


Link to post
Share on other sites
1 hour ago, pd27 said:

All log...

He meant the log files in `$HOME/.local/share/starconflict/logs/`. But they probably wont matter in this case

Share this post


Link to post
Share on other sites
15 hours ago, John161 said:

He meant the log files in `$HOME/.local/share/starconflict/logs/`.

Exactly

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.