TheDarkRedFox

Zero damage acts like damage

Recommended Posts

1. Description of the problem, what happened.

When damage is blocked, or damage is reduced below 1, it applies 0 damage to the user as seen on screen via the damage indicator. This zero damage will effect your ship as if it was real damage. For instance it will cancel the hull restoration system or a tackler's cloak. This is a huge problem and should be fixed asap.

2. What did you expected to happen.

I expected blocked damage to not affect my ship in any way.
3. The conditions during the situation.

Any game mode using any ship that can negate damage. (using emergency barrier or other invulnerability items)
4. Further details on the issue.

It shouldn't happen.
5. Frequency of occurrence.

100%

Share this post


Link to post
Share on other sites
2 hours ago, TheDarkRedFox said:

When damage is blocked, or damage is reduced below 1, it applies 0 damage to the user as seen on screen via the damage indicator.

Please make screenshots and logs

Share this post


Link to post
Share on other sites
6 hours ago, Skula1975 said:

Please make screenshots and logs

How to reproduce:

1: go in to any mode

2: activate ECM Metastable Energy Field Generator

3: take damage

4: watch damage numbers and see zero.

 

 

Easiest way to see it is the ECM special module, but any invulnerability effect works.

Share this post


Link to post
Share on other sites
3 hours ago, TheDarkRedFox said:

How to reproduce:

1: go in to any mode

2: activate ECM Metastable Energy Field Generator

3: take damage

4: watch damage numbers and see zero.

 

 

Easiest way to see it is the ECM special module, but any invulnerability effect works.

You can also replicate this if you got an invulnerability status active on your ship.

Share this post


Link to post
Share on other sites
1 minute ago, Koromac said:

You can also replicate this if you got an invulnerability status active on your ship.

yeah. like I said any invulnerability effect works.

Share this post


Link to post
Share on other sites
10 hours ago, Skula1975 said:

Please make screenshots and logs

Not a bug. This is working as intended.

Any damage should be detected and applied. If a target is immune to such damage, it should display 0s' when damage is ignored or blocked.

 

This bug report can be closed now.

Share this post


Link to post
Share on other sites
Just now, TheDarkRedFox said:

yeah. like I said any invulnerability effect works.

There is nothing wrong with showing 0s. This is actually how I wanted it to work from the beginning.

Share this post


Link to post
Share on other sites
15 minutes ago, Koromac said:

There is nothing wrong with showing 0s. This is actually how I wanted it to work from the beginning.

The fact that it displays 0 isn't the bug. The fact that the 0's will cancel positive effects is the bug.

Share this post


Link to post
Share on other sites

logs: 2018.06.21 11.09.34.zip

 

see last custom battle. Really quick test.

@Skula1975

 

11:18:08.280  CMBT   | Spell 'CivilianRepair_T5_Epic' by TheDarkRedFox(Module_CivilianRepair_T5_Epic) targets(1): TheDarkRedFox
11:18:08.280  CMBT   | Spell 'Talent_SlowResist' by TheDarkRedFox targets(1): TheDarkRedFox
11:18:08.280  CMBT   | Heal      TheDarkRedFox|0000000341 ->    TheDarkRedFox|0000000341 590.00 Module_CivilianRepair_T5_Epic
11:18:08.331  CMBT   | Apply aura 'CivilianRepair_T5_Epic' id 156 type AURA_HEAL_HULL_PERIODIC to 'TheDarkRedFox'
11:18:08.332  CMBT   | Apply aura 'Talent_SlowResist' id 157 type AURA_SLOW_IMMUNE to 'TheDarkRedFox'
11:18:09.000  CMBT   | Spell 'BlackoutGenerator' by TheDarkRedFox(Module_BlackoutGenerator_T5_Base) targets(1): TheDarkRedFox
11:18:09.000  CMBT   | Spell 'BlackoutGeneratorGapCloser' by TheDarkRedFox(Module_BlackoutGenerator_T5_Base) targets(1): TheDarkRedFox
11:18:09.001  CMBT   | Apply aura 'BlackoutGenerator' id 158 type AURA_FORTIFICATION to 'TheDarkRedFox'
11:18:09.234  CMBT   | Heal      TheDarkRedFox|0000000341 ->    TheDarkRedFox|0000000341 590.00 Module_CivilianRepair_T5_Epic
11:18:10.237  CMBT   | Heal      TheDarkRedFox|0000000341 ->    TheDarkRedFox|0000000341 590.00 Module_CivilianRepair_T5_Epic
11:18:10.303  CMBT   | Cancel aura 'Talent_SlowResist' id 157 type AURA_SLOW_IMMUNE from 'TheDarkRedFox'
11:18:10.355  CMBT   | Cancel aura 'CivilianRepair_T5_Epic' id 156 type AURA_HEAL_HULL_PERIODIC from 'TheDarkRedFox'
11:18:10.471  CMBT   | Damage          VanPaul|0000000170 ->    TheDarkRedFox|0000000341   0.00 (h:0.00 s:0.00) Weapon_Plasmagun_Heavy_T3_Epic EMP|PRIMARY_WEAPON  

As you can see, when I became invulnerable and was hit, it dealt 0 damage yet canceled the healing effect.

Share this post


Link to post
Share on other sites

You may have a point here, but 0 damage can still be considered as damage, or rather, a hit to disrupt the effect. Same goes for Pirate and Engine Overcharge.

Some modules cancel its effect, others don't. There are other examples as well.

Share this post


Link to post
Share on other sites
23 minutes ago, Koromac said:

You may have a point here, but 0 damage can still be considered as damage, or rather, a hit to disrupt the effect. Same goes for Pirate and Engine Overcharge.

Some modules cancel its effect, others don't. There are other examples as well.

Not the same. Invulnerability means invulnerability. It doesn't mean "you won't take 'real' damage but the effects of the damage will still disrupt all of your vital equipment".

 

I first noticed this when the 0 damage from the specops destroyer gravity pull constantly un-cloaked me in my tackler. I was never taking any actual damage, but the 0 damage still disrupted the effect.

Share this post


Link to post
Share on other sites
1 hour ago, Skula1975 said:

We decied that it isn't critical issue

Okay, so you decided to ignore this issue?

  • Thanks 1

Share this post


Link to post
Share on other sites

I think Koromacs explanation would even make sense in a realistic environment. Your ship might be able to survive a hit without taking damage, but it can still shake your ship around and disrupt some systems. It doesn't seem like a bug either.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.