Akaurl

Star Conflict 1.5.2 (Discussion)

Recommended Posts

On 5/26/2018 at 6:39 PM, Exarus said:

I've been crashing like crazy since this last mini-patch. I don't know what's going on, but at this point I know it isn't my computer. Before the update, it wasn't as bad, and though I haven't changed anything on my computer, the crashing is worse. Please, please fix this. I really would like to enjoy the game again...

Developers are not omniscient! They need data to be able to identify the problem.

 

When you got an issue, report it in the Bug Report section, with all the logs included. Only then can your problem get ID tagged, and eventually, worked on.

 

If you need help, you can check here:

 

Use this standard form for bug reports:

 

Also, do not forget to include DxDiag file in your case.

 

 

Now it's your turn.

Share this post


Link to post
Share on other sites

Crash city ever since I "came back" to the game. Been sending the crash reports, but I'm not going to make bug reports for CtD at random times...

Share this post


Link to post
Share on other sites

Meanwhile in Star Conflict PvP

 

sxw9CgJ.png

 

So many crashes in one day and STILL NO FIX :dntknw:

 

Oh and Iridium Strand might be f**ked. I half-loaded into it and the skybox was missing (red/white image - no texture file)

Share this post


Link to post
Share on other sites

Meanwhile on Win 10 like all people should

Untitled.png

I haven't crashed in weeks, you people need to stop using those bootleg OSs and get better potato PCs

Share this post


Link to post
Share on other sites
1 hour ago, xXThunderFlameXx said:

Meanwhile on Win 10 like all people should

Untitled.png

I haven't crashed in weeks, you people need to stop using those bootleg OSs and get better potato PCs

Actually it is not related to OS or how strong your PC is. I also heard if crashes from people with Win 10.

 

And since we share the content of our log folders, not a single crash and also not on Windows 10. (I'm only confused why there is still a folder from Jan)

ls -l .local/share/starconflict/logs 
total 84
drwxr-xr-x 2 john john 4096 Jan  7 17:46 '2018.01.03 13.20.29'
drwxr-xr-x 2 john john 4096 May 23 20:12 '2018.05.23 20.12.12'
drwxr-xr-x 2 john john 4096 May 23 21:29 '2018.05.23 21.29.18'
drwxr-xr-x 2 john john 4096 May 24 00:24 '2018.05.24 00.24.04'
drwxr-xr-x 2 john john 4096 May 24 19:41 '2018.05.24 19.41.18'
drwxr-xr-x 2 john john 4096 May 24 21:51 '2018.05.24 21.51.33'
drwxr-xr-x 2 john john 4096 May 25 15:10 '2018.05.25 15.10.06'
drwxr-xr-x 2 john john 4096 May 25 17:38 '2018.05.25 17.38.10'
drwxr-xr-x 2 john john 4096 May 26 01:48 '2018.05.26 01.48.24'
drwxr-xr-x 2 john john 4096 May 26 20:27 '2018.05.26 20.27.25'
drwxr-xr-x 2 john john 4096 May 26 21:06 '2018.05.26 21.06.33'
drwxr-xr-x 2 john john 4096 May 26 21:26 '2018.05.26 21.26.28'
drwxr-xr-x 2 john john 4096 May 27 16:38 '2018.05.27 16.38.05'
drwxr-xr-x 2 john john 4096 May 27 21:48 '2018.05.27 21.48.40'
drwxr-xr-x 2 john john 4096 May 28 01:42 '2018.05.28 01.42.17'
drwxr-xr-x 2 john john 4096 May 28 21:09 '2018.05.28 21.09.31'
drwxr-xr-x 2 john john 4096 May 29 19:42 '2018.05.29 19.42.47'
drwxr-xr-x 2 john john 4096 May 30 01:13 '2018.05.30 01.13.32'
drwxr-xr-x 2 john john 4096 May 30 11:17 '2018.05.30 11.17.05'
drwxr-xr-x 2 john john 4096 May 30 14:51 '2018.05.30 14.51.50'
drwxr-xr-x 2 john john 4096 May 30 14:54 '2018.05.30 14.54.52'

 

Share this post


Link to post
Share on other sites

It could also be because of missing updates, or installed software that can cause issues, but the idea is about the same.

Share this post


Link to post
Share on other sites
1 hour ago, xXThunderFlameXx said:

Meanwhile on Win 10 like all people should

Untitled.png

I haven't crashed in weeks, you people need to stop using those bootleg OSs and get better potato PCs

I'm on Windows 10 64bit with an i7 @ 2.8GHz, 16Gb RAM and a GTX1050. Moved SC from my HDD to SSD and the crash frequency reduced but still persists. Also had excessive crashes on another PC with Windows 10 again, i5, 8Gb RAM and a GT720 sooo you're probs just lucky.

Especially since when I try rejoin I see 4-6 people DC'd at a time.

Share this post


Link to post
Share on other sites

I'm on win10 as well and I have tons of crashes.

Already reported btw, will be fixed(i hope) on next update.

Share this post


Link to post
Share on other sites

Here's what's in my Crash Reporter log files...

 

01:18:21.599    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.601    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.603    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.605    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.607    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.609    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.611    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.613    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
etc, etc

etc, etc Failed to connect, game not in background. Will not try to reconnect.

 

Now game crash logs:

 

One game.log

...
01:17:45.293    ERROR| failed to load texture: models\ships\race_5\m\r5m_al_t1_nm
01:17:45.293    FATAL| Texture creation error: Direct3D out of memory on file: models\ships\race_5\m\r5m_al_t1_sc
01:17:45.293    ERROR| failed to load texture: models\ships\race_5\m\r5m_al_t1_sc
01:17:45.295    FATAL| ===!!! Out of system memory !!!===
01:17:45.295    FATAL| Unsuccessfully tried (1786 times) to allocate 4096 kb from Top
01:17:45.295    FATAL| System allocator borders 0xF6800000-0xF6BE0000
01:17:45.295  WARNING| ======================= MEMORY USAGE ============================
01:17:45.295  WARNING| Physical   : totl 32708.43M used     9308.96M free     23399.46M
01:17:45.295  WARNING| Virtual   :  totl 4095.88M used     4022.01M free      73.87M
01:17:45.295    FATAL| ===!!! Out of system memory !!!===

 

Another:

...

00:56:34.389    ERROR| [string "ui\scripts\work\helpers\metatext.lua"]:0: attempt to call method 'ResetItems' (a nil value)
Stack trace:
    =[C](-1)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)

00:56:34.389  WARNING| ^1UiEventManager::DeliverEventToUiObj - wnd: "HudObjectsMarksWnd", func: "F_OnNewFrame", error: "[string "ui\scripts\work\helpers\metatext.lua"]:0: attempt to call method 'ResetItems' (a nil value)

....

 

Another:

00:46:15.634    FATAL| Can't create vertex buffer :Direct3D out of memory

 

Actually, most of them are Direct 3D memory errors.

 

With 32GB RAM and 2x 4GB GPU's, what's going on here?

 

Share this post


Link to post
Share on other sites
24 minutes ago, RennieAshII said:

Here's what's in my Crash Reporter log files...

 

01:18:21.599    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.601    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.603    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.605    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.607    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.609    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.611    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
01:18:21.613    ERROR| HttpClient: corrupted request 0: handle 0EB0CA60, startTime 0.00
etc, etc

etc, etc Failed to connect, game not in background. Will not try to reconnect.

 

Now game crash logs:

 

One game.log

...
01:17:45.293    ERROR| failed to load texture: models\ships\race_5\m\r5m_al_t1_nm
01:17:45.293    FATAL| Texture creation error: Direct3D out of memory on file: models\ships\race_5\m\r5m_al_t1_sc
01:17:45.293    ERROR| failed to load texture: models\ships\race_5\m\r5m_al_t1_sc
01:17:45.295    FATAL| ===!!! Out of system memory !!!===
01:17:45.295    FATAL| Unsuccessfully tried (1786 times) to allocate 4096 kb from Top
01:17:45.295    FATAL| System allocator borders 0xF6800000-0xF6BE0000
01:17:45.295  WARNING| ======================= MEMORY USAGE ============================
01:17:45.295  WARNING| Physical   : totl 32708.43M used     9308.96M free     23399.46M
01:17:45.295  WARNING| Virtual   :  totl 4095.88M used     4022.01M free      73.87M
01:17:45.295    FATAL| ===!!! Out of system memory !!!===

 

Another:

...

00:56:34.389    ERROR| [string "ui\scripts\work\helpers\metatext.lua"]:0: attempt to call method 'ResetItems' (a nil value)
Stack trace:
    =[C](-1)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\work\helpers\metatext.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)
    ui\scripts\windows\hudobjectsmarkswnd.lua(0)

00:56:34.389  WARNING| ^1UiEventManager::DeliverEventToUiObj - wnd: "HudObjectsMarksWnd", func: "F_OnNewFrame", error: "[string "ui\scripts\work\helpers\metatext.lua"]:0: attempt to call method 'ResetItems' (a nil value)

....A

 

Another:

00:46:15.634    FATAL| Can't create vertex buffer :Direct3D out of memory

 

Actually, most of them are Direct 3D memory errors.

 

With 32GB RAM and 2x 4GB GPU's, what's going on here?

 

A simple memory leak. The bug got reported already multiple time.

Share this post


Link to post
Share on other sites

It could also be a software issue, not enough memory allocated to the game? I would think that it would allocate a proportionate amount of your memory by default, my single GTX 1060 3GB can handle it just well, even with other games or even Adobe programs running at the same time.

Share this post


Link to post
Share on other sites
54 minutes ago, xXThunderFlameXx said:

It could also be a software issue, not enough memory allocated to the game? I would think that it would allocate a proportionate amount of your memory by default, my single GTX 1060 3GB can handle it just well, even with other games or even Adobe programs running at the same time.

It's just hitting it's 4GB memory limit -  that's it. Over the years textures were added, more models were added but that limit stays. If it is a mem leak or simply running OOM because of extra textures/models - is for the dev team to determine. 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 5/24/2018 at 11:28 AM, Scar6 said:

Well, for my own sanity, no star conflict until june then xD

.. you've got my sympathy for that ;))

Share this post


Link to post
Share on other sites

1.5.2 patch discussion is not closed, same goes for 1.5.3. I'm not sure what's going on in there...

Share this post


Link to post
Share on other sites

inb4 lock

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.