apemax

[1.4.0b] Client not starting on Arch Linux.

14 posts in this topic

Hello,

The Star Conflict client does not launch on Arch Linux any more, I tried starting it today after a while of not playing and it won't launch either from Steam or the command line, The errors from the command line:

./StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./StarConflict)
./StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by ./StarConflict)

I have the latest version of both of these libraries installed however I believe the issue is that the game client requires older versions of these libraries. I've seen these errors before and thats usually the case.

I had a look but no game logs have been created.

My system information:

System:    Host: apes-pc Kernel: 4.9.6-1-ARCH x86_64 (64 bit)
           Desktop: Gnome 3.22.2 Distro: Arch Linux
Machine:   Device: desktop Mobo: ASRock model: Z97M Pro4
           BIOS: American Megatrends v: P1.40 date: 05/23/2014
CPU:       Dual core Intel Pentium G3258 (-MCP-) cache: 3072 KB 
           clock speeds: max: 4000 MHz 1: 4000 MHz 2: 4000 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 950]
           Display Server: X.Org 1.19.1 driver: nvidia
           Resolution: 1920x1080@60.00hz, 1280x1024@60.02hz
           GLX Renderer: GeForce GTX 950/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.26
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.6-1-ARCH
Network:   Card-1: Intel Ethernet Connection (2) I218-V driver: e1000e
           IF: enp0s25 state: up speed: 100 Mbps duplex: full
           mac: d0:50:99:3e:6f:af
           Card-2: Intel Wireless 7260 driver: iwlwifi
           IF: wlp5s0 state: up mac: d8:fc:93:42:95:e1
Drives:    HDD Total Size: 3000.6GB (47.7% used)
           ID-1: /dev/sdb model: ST2000DM001 size: 2000.4GB
           ID-2: /dev/sda model: ST1000DM003 size: 1000.2GB
Partition: ID-1: / size: 1.8T used: 1.3T (77%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 4.00GB used: 0.04GB (1%) fs: swap dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 43.5C mobo: 36.0C gpu: 41C
           Fan Speeds (in rpm): cpu: N/A fan-1: 1644 fan-2: 1267 fan-3: 0 fan-4: 2380 fan-5: 0
Info:      Processes: 204 Uptime: 11:53 Memory: 2989.1/7940.0MB
           Client: Shell (bash) inxi: 2.3.8 

 

0

Share this post


Link to post
Share on other sites

Yeah that it doesn't start from command line is 'normal' can you get the logs from steam when you start the game (open steam in command line and copy pasta the stuff that gets written father you press launch Star Conflict)

0

Share this post


Link to post
Share on other sites
On 29/01/2017 at 0:50 PM, John161 said:

Yeah that it doesn't start from command line is 'normal' can you get the logs from steam when you start the game (open steam in command line and copy pasta the stuff that gets written father you press launch Star Conflict)

Output when the game is launched through steam:

Game update: AppID 212070 "Star Conflict", ProcID 10513, IP 0.0.0.0:0
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 10513 for game ID 212070
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
>>> Adding process 10514 for game ID 212070
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
Game removed: AppID 212070 "Star Conflict", ProcID 10513 
No cached sticky mapping in ActivateActionSet.

Game doesn't start at all, Same errors as when launched directory from the command line.

6 hours ago, Skula1975 said:

Yes and I meet those system requirements, I'm actually using newer software than what is in the recommended Ubuntu version (14.04) which is actually over two years old now, Is this not going to get fixed until this same issue appears in Ubuntu or SteamOS?

0

Share this post


Link to post
Share on other sites
35 minutes ago, apemax said:

Output when the game is launched through steam:

Game doesn't start at all, Same errors as when launched directory from the command line.

I compared your logs to mine and the only difference is that  in both cases (steam and non steam)

./StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./StarConflict)

is also

./StarConflict: /usr/lib32/libcurl.so.4: no version information available (required by ./StarConflict)

Which is kinda strange since at least the steam libarys should be the same.

What libcurl variant are you using?

 

35 minutes ago, apemax said:

Yes and I meet those system requirements, I'm actually using newer software than what is in the recommended Ubuntu version (14.04) which is actually over two years old now, Is this not going to get fixed until this same issue appears in Ubuntu or SteamOS?

 

Ubuntu 14.04 is still a supported LTS version and yeah SteamOS is based on Debian 8 so don't expect any Steam Game to be build against any new libaries since Steam itself gets shipped with old ones.

0

Share this post


Link to post
Share on other sites
6 hours ago, John161 said:

I compared your logs to mine and the only difference is that  in both cases (steam and non steam)


./StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./StarConflict)

is also


./StarConflict: /usr/lib32/libcurl.so.4: no version information available (required by ./StarConflict)

Which is kinda strange since at least the steam libarys should be the same.

What libcurl variant are you using?

 

 

Ubuntu 14.04 is still a supported LTS version and yeah SteamOS is based on Debian 8 so don't expect any Steam Game to be build against any new libaries since Steam itself gets shipped with old ones.

Ok so I tried running SC using this command:

env "LD_PRELOAD=libcurl.so.3" ./StarConflict

And it got a bit further, Game launched and got to the loading screen but then crashed:

./StarConflict: /usr/lib32/libcurl.so.3: no version information available (required by ./StarConflict)
./StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by ./StarConflict)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Trace/breakpoint trap (core dumped)

Thing is every other Steam game works fine so it's clearly a issue with Star Conflict specifically.

0

Share this post


Link to post
Share on other sites
1 hour ago, apemax said:

Ok so I tried running SC using this command:


env "LD_PRELOAD=libcurl.so.3" ./StarConflict

And it got a bit further, Game launched and got to the loading screen but then crashed:


./StarConflict: /usr/lib32/libcurl.so.3: no version information available (required by ./StarConflict)
./StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by ./StarConflict)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Trace/breakpoint trap (core dumped)

Thing is every other Steam game works fine so it's clearly a issue with Star Conflict specifically.

Preload it for steam, I never tried to debug/find out why the game is crashing when started outside steam.

0

Share this post


Link to post
Share on other sites
14 hours ago, John161 said:

Preload it for steam, I never tried to debug/find out why the game is crashing when started outside steam.

Preloading it for steam doesn't seem to work:

env "LD_PRELOAD=libcurl.so.3" steam
Game update: AppID 212070 "Star Conflict", ProcID 5183, IP 0.0.0.0:0
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 5183 for game ID 212070
>>> Adding process 5184 for game ID 212070
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
Game removed: AppID 212070 "Star Conflict", ProcID 5183 
No cached sticky mapping in ActivateActionSet.

Has the crash if started outside steam ever been reported?

0

Share this post


Link to post
Share on other sites
2 hours ago, apemax said:

Preloading it for steam doesn't seem to work:


env "LD_PRELOAD=libcurl.so.3" steam

Game update: AppID 212070 "Star Conflict", ProcID 5183, IP 0.0.0.0:0
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 5183 for game ID 212070
>>> Adding process 5184 for game ID 212070
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
Game removed: AppID 212070 "Star Conflict", ProcID 5183 
No cached sticky mapping in ActivateActionSet.

Has the crash if started outside steam ever been reported?

I don't know but it will probably end in Skula saying that only Ubuntu and Steam OS is supported.

I'mstill curios which curl variant you are running? The gnu one? But I wouldn't be surprised if it is not curl that is causing the problem. Maybe attaching Smith like gdb or trace to get more information about the point where it has troubles would maybe help but at least I don't have any real experience in it.

0

Share this post


Link to post
Share on other sites
47 minutes ago, John161 said:

I don't know but it will probably end in Skula saying that only Ubuntu and Steam OS is supported.

I'mstill curios which curl variant you are running? The gnu one? But I wouldn't be surprised if it is not curl that is causing the problem. Maybe attaching Smith like gdb or trace to get more information about the point where it has troubles would maybe help but at least I don't have any real experience in it.

I'm using the default curl from the Arch repo:

https://www.archlinux.org/packages/multilib/x86_64/lib32-curl/

I've been reading and it would seem as though Steam it's self uses this old version of CURL_OPENSSL in it's own libraries, So question is why isn't start conflict using that one?

Ok so this is weird, If I start steam using "steam-native" Star Conflict will run fine, "steam-native" is suppose to use your own libraries instead of the ones that come with steam, The Steam runtime as it's called. Yet when steam is started using "steam-runtime" Star Conflict doesn't run, Does this make any sense?

0

Share this post


Link to post
Share on other sites
22 hours ago, apemax said:

I'm using the default curl from the Arch repo:

https://www.archlinux.org/packages/multilib/x86_64/lib32-curl/

I've been reading and it would seem as though Steam it's self uses this old version of CURL_OPENSSL in it's own libraries, So question is why isn't start conflict using that one?

Ok so this is weird, If I start steam using "steam-native" Star Conflict will run fine, "steam-native" is suppose to use your own libraries instead of the ones that come with steam, The Steam runtime as it's called. Yet when steam is started using "steam-runtime" Star Conflict doesn't run, Does this make any sense?

Install the steam-native package or enforce the Steam Runtime (i can't rememeber the enviroment vraiables for that)

0

Share this post


Link to post
Share on other sites
22 hours ago, John161 said:

Install the steam-native package or enforce the Steam Runtime (i can't rememeber the enviroment vraiables for that)

I have the steam-native-runtime package installed already. What I don't get is why it works with steam-native (Not using the Steam runtime libraries) but doesn't work with steam-runtime (Supposedly using the Steam runtime libraries.)

Ok so heres the output of launching SC from steam native:

Game update: AppID 212070 "Star Conflict", ProcID 21360, IP 0.0.0.0:0
>>> Adding process 21360 for game ID 212070
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/steam/libcurl.so.4: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
>>> Adding process 21361 for game ID 212070
Setting breakpad minidump AppID = 212070
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197994511920 [API loaded no]
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 21366 for game ID 212070
Installing breakpad exception handler for appid(gameoverlayui)/version(20170119012220)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
>>> Adding process 21367 for game ID 212070
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Game removed: AppID 212070 "Star Conflict", ProcID 21361 
No cached sticky mapping in ActivateActionSet.

It looks like it's loading the steam version of libcurl.so.4 instead of the system libcurl.so.4, Any idea whats going on here?

0

Share this post


Link to post
Share on other sites
4 hours ago, apemax said:

I have the steam-native-runtime package installed already. What I don't get is why it works with steam-native (Not using the Steam runtime libraries) but doesn't work with steam-runtime (Supposedly using the Steam runtime libraries.)

Ok so heres the output of launching SC from steam native:


Game update: AppID 212070 "Star Conflict", ProcID 21360, IP 0.0.0.0:0
>>> Adding process 21360 for game ID 212070
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/steam/libcurl.so.4: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
/home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict: /usr/lib32/libcrypto.so.1.0.0: no version information available (required by /home/apemax/.local/share/Steam/steamapps/common/star conflict/StarConflict)
>>> Adding process 21361 for game ID 212070
Setting breakpad minidump AppID = 212070
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197994511920 [API loaded no]
ERROR: ld.so: object '/home/apemax/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 21366 for game ID 212070
Installing breakpad exception handler for appid(gameoverlayui)/version(20170119012220)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
>>> Adding process 21367 for game ID 212070
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Game removed: AppID 212070 "Star Conflict", ProcID 21361 
No cached sticky mapping in ActivateActionSet.

It looks like it's loading the steam version of libcurl.so.4 instead of the system libcurl.so.4, Any idea whats going on here?

 

 

 

Damm it feels linke this forum has more bugs every day(Or it is a compatibility issue with AndroidFirefox, this is why I'm answering isnode this quote)

My game is broken too since yesterday, probably because of a system update (Manjaro is afaik often some days behind Arch). I haven't tried to figure anything out and just used wine for playing it(has some performance issues when a battle is starting but after that it runs smoother then the native version)

Now made a test and it is the a updated package but idk which since my update on my 2nd system were around 420 packages and I don't remember the few packages that got updated on my main.

 

 

0

Share this post


Link to post
Share on other sites
On 02/02/2017 at 3:45 PM, John161 said:

 

Damm it feels linke this forum has more bugs every day(Or it is a compatibility issue with AndroidFirefox, this is why I'm answering isnode this quote)

My game is broken too since yesterday, probably because of a system update (Manjaro is afaik often some days behind Arch). I haven't tried to figure anything out and just used wine for playing it(has some performance issues when a battle is starting but after that it runs smoother then the native version)

Now made a test and it is the a updated package but idk which since my update on my 2nd system were around 420 packages and I don't remember the few packages that got updated on my main.

 

 

Yeah, Been playing it through steam-native now, Seems to work fine so I suppose this is the best it can get for now.

Manjaro uses pacman right? It keeps a log of all packages it installs/updates in /var/log/pacman.log so perhaps you could find out from there?

0

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.